Only Half of RAM Works

I have 16gb of Ram installed in my system but only half of it is usable.  When I boot with ....

1 Stick : 4GB is usable

2 Sticks: 4GB is usable

3 Sticks : 8GB is usable

4 Sticks : 8GB is usable

 I am running into problems where games crash because I have tons of things in the background that I don't want to end.  I have had this problem for a year and have tried fixing it with no luck.  It hadn't made a difference until now because Dragon Age Inquisition actually uses more than 6GB of RAM.  My BIOS is the most recent version.  The amount of memory available does not depend on which stick(s) I put in.  I have changed the advanced boot options so there is no maximum memory limit and I have tried with a 16384 GB limit and it makes no difference. I have tried running the memory sticks at 800mHz, 1333mHz and 1600mHz and that makes no difference too.  Any ideas?


System Specs

FX 8320 @ Stock

Asus M5A99FX PRO R2.0

2x CORSAIR Vengeance 8GB (2 x 4GB) CMZ8GX3M2A1600C9

XFX 7970 Ghz Double Dissipation @ Stock

OS: Windows 8.1 64 Bit


Could be an issue with your ram slots.  If slots 2 and 4 (A2 and B2) weren't working correctly, it could present like that.  Try and boot with sticks just in those slots.  If it's a no go, then it could just be dirty, or possibly a bent pin.  It could also be a bent/bad pin on your CPU that is causing it, so that's something I would check for.

One other thing to check is your memory mapping settings in the bios.  Make sure it's enabled.  Should be under memory configuration or something similar.

If I were you, I'd try only the two sticks you know work in the other slots first. Then, after this, use only the two 8gb sticks in the working slots. 


This may eliminate what I suspect the problem is: Incompatible ram sticks since you are using 2 4gbs and 2 8gb. While Ram is generally QUITE forgiving when it comes to using different sticks together, they can still be a little finicky which is why people always recommend buying verified sets. 

Physical hardware may also be the issue; ie bent ram pins or broken slots etc. The first step should verify this. 

You should also make sure you are bot running an OC on your memory as windows does not like it when you overvolt memory (I think the limit is 1.6V as I recall before it doesn't recognise it). 

maybe your max memory at bootup is set with a limit in ms-config. 

You could change that in ms-config.

Just uncheck the max memory checkbox, and then save and reboot.

It does not matter which ram dimm I put in.  The RAM slot used doesn't matter, makes no difference.  I do have memory re-mapping enabled in my BIOS.  Not of my memory is overclocked.  I've even tried underclocking.  All my sticks of ram are the same so compatibility between them is not a question.  Disabling max memory in ms-config made no difference.

That motherboard is known to have problems running Corsair RAM. So you may be out of luck.

The same exact memory of mine but in a 4x4GB set is on the QVL List.  Same Voltage, speed, and timings.  Even same color(doesn't matter).  I can try some GSkill Memory tomorrow and see if that solves it.

I hope that will fix the problem for you.

i dont have any problems with corsair ram on my Asus M5A97 EVO R2.0 board.

just check ms-config like i said.

Ah ok, didnt read that.

But corsair ram should work totaly fine on that mobo.

He could try the mem ok button, or just a bios reset.

Have flashed the bios multiple times and cleared CMOS.  Isn't the MemOK button if your board wont POST due to memory problems?  If I go into the North Bridge > Memory Configuration it shows all 4 RAM Slots are filled with 4096MB.

He's not using mismatched sets.  He has 4x4gb for 16gb total.  He was listing the total amount of ram available when he puts another stick in each slot.  Meaning with 2x4gb sticks inserted, he only has 4gb available.  With 3x4gb inserted, he now has 8gb available and so on.

So it boots fine with sticks only installed in A2 and B2 then?

then i suppose there is something wrong with your mobo most likely.

i would RMA it.