Return to Level1Techs.com

One of my Freenas bootdrives failed, can't replace | Help

#1

Hey guys,

One of my Freenas boot usb drives decided to crap out.
And now i can’t replace the failed boot drive.

It keeps saying
" * [EFAULT] ‘gpart create -s gpt -f active /dev/da0’ failed: gpart: geom ‘da0’: File exists"

Then i ran
“gpart delete -i 1 da0”
and
“gpart destroy da0”

and now i got this error
" * [EFAULT] ‘newfs_msdos -F 16 /dev/da0p1’ failed: newfs_msdos: /dev/da0p1: Operation not permitted"

running freenas 11.2

Please help me.

0 Likes

#2

Not enough info sonnyjim,

This is all I can think of for you to read to help? Soz bruh :slight_smile:

0 Likes

#3

Back up configuration, install freenas to new USB(s), restore configuration?

1 Like

#4

what info would you like to have?
I’ll give it.

Also i indeed saw that post, and tried the command with the right amount of sectors.
The command ran fine but it did not solve the problem.
Had to destroy da0 again after that.

These are brand new usb’s.
But what’s the point of running redundant boot drives if i can’t replace one when it goes down?

0 Likes

#5

A valid question, however i was taking a pragmatic standpoint… i.e., how to resolve the issue using a known process that should work.

0 Likes

#6

It’s just like saying my headlight is not working how do i replace the bulb?
just buy a new headlight it already has a bulb in it.

I’d like to fix the core of the problem.
Your solution is indeed a solution, but it’s a last resort solution.
I really don’t have much time to f around with these things anymore it just needs to work.

I do really hope you have the knowledge to help me fix the core of this problem.

0 Likes

#7

I’m the same - this is why i made the suggestion i did. 15 minutes work, tops.

Nope, good luck with your investigation.

0 Likes

#8

“F” has been pressed

0 Likes