Older rooted tablet (TF201) - issues flashing (but TWRP works). Any ideas?

Hi folks,

I’ve got an older ASUS TF201 which, at the moment, is a beached (tiny) whale.

It gets into TWRP no problem, but trying to flash the stock ROM only results in an error, and it will not complete.

I have tried some custom firmware (through TWRP) that are known to work on the tablet. The flash process completes successfully (no errors), but still, the tablet refuses to boot into Android.

Is there something I’m missing, or is this tablet a lost cause? I merely want it to boot into the OS again, as I’m loathe to turn this working piece of hardware into e-waste over something I might have missed.


That was a decent tablet. I had one back in the day. Kind of an android version of surface pro. I won’t be any help. Have you asked on xda developers? Otherwise someone else might be able to help on here other than myself.

1 Like

I’ve seen different ROMs use different partition layouts. I would check what’s expected vs what you have. Sometimes it’ll silently fail if the partitions aren’t configured in the exact correct manner.

I’ll give the XDA community a whirl, thanks for the tip.

1 Like

I had wondered about this, but I’m entirely clueless when it comes to setting up the internal flash memory with partition layouts, etc.

In various places online, I have found - numerous times - what sounds like the solution, only to find that these do not work either.

From what I can tell, the firmware images use an executable, and in the case of the ASUS provided “official” firmware, this executable checks for some (unknown) conditions, and then returns an error if these are not met. I’m wondering if the fact my tablet is rooted is causing the failure.

As for the third party images I have tried, which are known to work, these complete the flash without errors, but yet the tablet remains in its current state, i.e., it stalls when attempting to start Android.

I’m really at a loss now, but I shall try posting in the XDA community (once I find it) to see if anyone might have some suggestions. As you said, if I could figure out what the correct partition layout needs to be, and how to go about setting that up, that might be the solution.


Just a shot in the dark. I ran into that on my OP5 recently, but I don’t know if they started messing with partition layouts back in the TF201 days.

Definitely check with XDA.

First, boot a rom through adb without flashing. If you can get something to just boot, have a look around fr there.

1 Like