Okay, I'm completely stumped

Okay, I am stumped(in case you couldn't tell from the title).


I have a laptop that is incredibly old. When I say old I mean this thing hasn't seen the internet since 2004. My issue is actually connecting to the Internet. This laptop is wifi compatible, and I am connected to the Internet. I try to connect through Internet Explorer, and it says there is no connection. Okay, so I can use the little tools built into Internet Explorer to get this working right? Of course not, that would be too easy. IE only seems to recognize two options that I can connect to. IE doesn't recognize the wifi adapter, my guess is that IE is too old. This IE is from the days when it actually opened within 30 seconds. Note at the bottom


My next plan was to install a more up to date browser, such as Google Chrome. All of the system requirements check out: 128MB of RAM(this has 448), Pentium 4(same). The only issue with this is that GC supports Windows XPSP2 and above. Well it is just my luck that this lovely machine has SP1. Hm okay, I'll use Windows Update to get the newest SP. I already knew this was a long shot because Windows stopped supporting XP(just my luck, right?). I tried it anyway. Well guess what Windows Update uses to check for updates? If you guessed Internet Explorer, you are correct. So where am I? Back to square one. I have no idea what else to do. Any ideas?


Later down the line I plan to install Linux but I'm one of those people who like to see everything working one last time before I change everything. This mentality has lost me a few clumps of hair and, I'm almost sure, a few years of my life span.


Note: When I look under Network Connections there's two categories: Dial Up and LAN or High Speed Internet. Under dial up it says Soft Disk(in gray: Disconnected, firewalled. TOSHIBA Software Modem) and Omega(in gray: Disconnected. TOSHIBA Software Modem). Under LAN or High Speed Internet it says Local Area Connection(in gray: Disabled(by me). Realtek RTL8139/810X Family Fast Ethernet NIC), Wireless Network Connection(in gray: Enabled. Atheros AR5004G Wireless Network Adapter), and 1394 Connection(in gray: Disabled(by me). 1394 Net Adapter). When I click on the Internet settings under IE, the only things that pop up are the ones under Dial Up, I'm not sure why this is.


The Laptop is/has

  • TOSHIBA Satellite
  • Pentium 4 Mobile 3.06 GHz. Something doesn't add up here because right under that it says 3.07GHz. Oh well. What difference could it make
  • 448MB RAM(Yes I meant to put an M there)
  • 60 GB? HDD

Believe me, any information you need I will get you in a heartbeat

ok what are you going to do with this recycling  

Have you tried a wired connection? If you can get access through a wired connection then let all teh windows updates install and such you might be fine.

I'm not sure if it's IE or not, but if you wanna try a different browser, you can get extremely old versions of firefox here: http://www.oldapps.com/firefox.php?system=windows_xp

Also here's a way you can update windows xp to service pack 3 without using windows update (its under the manual install): http://windows.microsoft.com/en-us/windows/help/learn-how-to-install-windows-xp-service-pack-3-sp3#

Hope I helped :P

I'm going to put Linux on this and practice my coding

Yes you certainly put me in the right direction. I ended up deleting the softwhatever and omega stuff. I deleted everything in network connections except for the stuff I knew worked. Firefox wouldn't connect because of something having to do with a proxy. There was an option under Internet Settings that mentioned something about a proxy, I unchecked it. BOOM. Everything works like a charm. I'm going to check to see if Wifi will cooperate tomorrow. 


I saw somewhere that SP3 can't be installed without SP2 being installed beforehand. Do you know of a download for SP2 as well?

Just install Lubuntu on it. You'll be better off.

Believe me, I know I would. I have to back this stuff up though first because this laptop isn't mine to begin with, it's my grandmothers. 

Okay I have tried to work with the wifi a bit and neither Firefox nor IE will cooperate with the wifi. I'm not sure what to do about that. I know the adapter works so I don't think it's an adapter issue. I have tried everything, well everything that I can think of to do. I'll just plug it in to ethernet and let this thing update and see if that fixes anything. 

Service pack 2:  http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=28

Service pack 3:  http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=24

Have, you turned off the proxy settings for the wi-fi connection as well? I havent used xp in quite a while, but in internet options i think the connections tab is only used for dial-up connections, its usually best to have everything there set to automatically detect.

Thanks, I saw on a Microsoft's support site that SP2 has to be installed first if SP1 is not installed. I am downloading SP3 right now. I'll do a quick back up then update Windows and see if that fixes anything.

Okay. SP3 is installed and works fine. I downloaded the most up-to-date driver I could find for this adapter(from 2012 or so). The last issue that I am having is that when Windows begins to connect to the router, it throws this message, "Windows was unable to find a certificate to log you on the network NETGEAR21". Is this message telling me that there are too many people using the network and it can't assign me a spot on the network?

Another thing, when I disconnect and try to connect again, Windows seems to hang on, "Waiting for the network to be ready". I don't mean hang as in freeze but it stays on that screen. I am also beginning to think that this might be a router issue instead of the computer causing this

boot it up from a usb and see if the problem persists. If not, then dual boot it, copy the files to external hard drive, then do a clean install.