[Obsolete/Solved] Moving to FreeNAS 10 - a good idea?


Once and again FreeNAS update broke all my VirtualBox VMs; It is getting old - I installed it, and also bought the motherboard and lots of RAM because I could virtualize.

As the FreeNAS devs, definitely have no plan on fixing that, and in every bug report I could google they are refering to the 10 release - I am not tempted to Upgrade.

But can I go back to the stable train from nightly? - I mean from 10 nightly to 10 stable when its finally out?

One little bump - before I give up

So your on Freenas 10 now or you updated to it from 9.10?

I am on 9.10.1 and realy upset with my VMs not working... even contemplating to switch to esxi and virtualize even FreeNAS on it.

But my inital question just got made redundant, as switching trains is not supported. They state one can not yet move from 9.10.1 to 10 so yeah.. obsolete.

Traceback (most recent call last):
File "/usr/local/www/freenasUI/../freenasUI/system/views.py", line 1451, in update_check
File "/usr/local/lib/freenasOS/Update.py", line 870, in CheckForUpdates
File "/usr/local/lib/freenasOS/Manifest.py", line 664, in RunValidationProgram
raise Exceptions.UpdateInvalidUpdateException(err.output.rstrip())
UpdateInvalidUpdateException: 'Cannot yet upgrade from FreeNAS 9.x to FreeNAS 10'

What I was trying to find out was, weather I can move to 10-stable if I now move from 9.10 stable to 10-nightly ^^

Thanks for reply @sanfordvdev , but @moderators that topic is obsolete.

So, I can't help with your current problem, but I feel the need to point this out if you are serious about virtualizing FreeNAS. It can be done, but there are many caveats and considerations you need to go over first.


1 Like

Are you using iohyve on 9.10 for your VMs?
I'm using iohuve and it has survived at least 3 updates and I'm running three Ubuntu vms on it.

oh - that I did not know about that - answers as a no O.o
Thank you very much, I will try that asap!

Ok trying it now - but I am stalled by this error:

iohyve fetch /mnt/volume02/jails-data/vbox-share/debian-8.6.0-amd64.iso 
Fetching /mnt/volume02/jails-data/vbox-share/debian-8.6.0-amd64.iso...
fetch: /iohyve/ISO/debian-8.6.0-amd64.iso: open(): No such file or directory

but in the /iohyve/ISO/ path there is a folder with exactly the name debian-8.6.0-amd64.iso created.

This is the tutorial i followed

Same that I just tried - and it seems that there are several bugs in 9.10 involving iohyve - well a ln -s solved the iso problem so far but more to come. Thanks for mentioning it to me, I will keep on digging the google to get it working

But it also seems more like a mess (workaround) than a solution in FreeNAS at the moment.