NvidiaGPU Passthrough on a lenovo y720 with proxmox for windows guest

Hello there,

Since the pandemic kept me in the house, I built a desktop and my 3-year-old gaming laptop was just lying around, so I thought I’d slap proxmox on it and play around for a bit.

My issue is that I tried following multiple guides, including the one proxmox provided and “The ultimate beginner’s guide to gpu passthrough” from /r/homelab (can’t post the link :frowning: ).

In short:

  • I updated grub parameters with GRUB_CMDLINE_LINUX_DEFAULT=“quiet intel_iommu=on iommu=pt video=efifb:eek:ff”
  • I blacklisted nouveau, nvidiafb, nvidia
  • I added the ids to get the vfio-pci module(I think that’s what this does) (options vfio-pci ids=10de:1c20,10de:10f1 in a file in modprobe.d)
  • I added options kvm ignore_msrs=1 in another file in modprobe.d
    *Added the video card with all the checks in place
  • Added options vfio_iommu_type1 allow_unsafe_interrupts=1 in another file in modprobe.d
  • Added vfio ,vfio_iommu_type1, vfio_pci, vfio_virqfd in /etc/modules

It seems IOMMU is supported on this laptop, since I have the option to add a pci e device in the proxmox menu.
What I haven’t seen addressed(since it’s a laptop and I’ve never found a weirdo like myself that’d put proxmox on a laptop :sweat_smile: ) is the fact that the graphics card and the pci bridge share the same IOMMU group. I have no idea if that’s what’s causing the issue, or how to solve it.

I installed windows 10 and all on the guest, but the device doesn’t show up properly:

Installing the nvidia driver doesn’t work since it doesn’t pick up the GPU (I imagine windows would’ve picked it up and installed its own driver if it did work)

I tried specifying a ROM file for the GPU, but it seems even if I do “echo 1 >/sys/devices/[…]/[gpuaddr]/rom” then try to dump it somewhere else I get an error.

For the record, I’m using the latest proxmox at the time of posting(6.2-10), a lenovo y720 with a 7700hq and a gtx 1060 6GB.

If I forgot any other troubleshooting info let me know

Anyone wants to join me on a troubleshooting adventure?

More pictures since I’m limited to two in the original post:

GPU together with the bridge in the IOMMU group: image

gpu + vm configuration: