NVIDIA drivers give me a black screen when I reboot into Ubuntu

When I install the Nvidia drivers on Ubuntu, I get a black screen. I've tried installing it multiple ways and it gives me the same outcome every time. Is there anyone out there that can help me? @wendell might be able to help me.


What video card are you using? I had a 210 running without issues.

Have you had a look at this? http://askubuntu.com/questions/41681/blank-screen-after-installing-nvidia-restricted-driver

Sorry if you already have, it was just a suggestion.


Hi, I'm using a GTX Titan. Not a Titan black or Z, just a Titan. I have also tried things similar to that, but not exactly.

Have you stumbled across these by any chance?


Yeah I had this problem as well while installing ubuntu a while back. I gave up and now I'm using kubuntu. I don't know why it works for kubuntu but not for ubuntu. It just works. I'm using a gtx 750ti

No, but I will check it out.

The only problem I see happening here is that I'm using gnome with it and I don't think there was that "Restricted Drivers Available" button was there.

I'm thinking about just switching to OpenSues, I wonder if that will work.

Meh, I mean drivers should be drivers. The only thing opensuse MIGHT do for you is let you use a more recent driver?

Out of curiosity, what driver version where you using?

I think it was 313.67 or something close to that.

Well there is your problem.

That driver is as old as the dinosaurs, and does not work all that well with the titan.

I recommend you try to install version 346 or newer.

If you are only getting a black screen, then go ahead and give openSUSE a shot. You can use YaST to install the latest drivers without too much trouble.


Yeah I find that you just have to experiment with different distributions and find one that just works for you. I've tried Sabayon as well and my gpu worked well in there. I didn't end up with Sabayon because I had an audio issue. I knew how to fix it but it required doing the same process every time I boot so it was too annoying.

When the screen is black you can press ctrl alt F1 for the console. Then remove the drivers:

sudo apt-get purge nvidia*;

Make sure you have the new libraries:

sudo add-apt-repository -y ppa:xorg-edgers/ppa
sudo apt-get update

then sudo apt-get install nvidia-346
using this might do the same: sudo apt-get install nvidia-current


Thanks, @Logan. This is what I was looking for!

I've tried this many times, but I'm completely stuck on the black screen with blinking underscore..... just so you know, I'm running a GTX 970 (Gigabyte G1 Gaming to be exact) and using the 346 nvidia driver...... do you think a complete reinstall of Ubuntu (standard running Unity) would be a good idea or should I seek out a different distro? The last time I had Ubuntu run well on me was with my good old Sapphire Radeon HD7970 Dual-X OC! :|

Thanks in advance mate! Hope all is well with you guys!

Try this, any this is only my suggestion:
When your at the black screen , press control alt F2. This should take you to a terminal screen.
sudo -i
cd /usr/local/bin && wget -O sgfxi smxi.org/sgfxi && chmod +x sgfxi && sgfxi

then type sgfxi
Run through the script its very simple
This script takes care of the nvidia driver installs. However everytime your kernel updates, you will get a black screen upon rebooting. Just press control alt F2 again type sudo sgfxi and run through the install.

I have done this many times on my linux mint install even though it has a built in tool to automatically install and update drivers upon kernel update. So you may want to look into linux mint as well to make it even easier. But the above should get you up and running.

Thanks for the help mate! will give it a try soon and get back to you, if no success I'll try out Linux Mint..... or maybe even OpenSuse.... both sound like interesting options! :)

looks like no luck unfortunately! tried a few times, using different methods including nomodeset and just won't budge past the black screen, gonna give OpenSuse a try and see what happens there! ..........nvidia will be the death of me :P

Sorry it didn't work.

You could always try linux mint if your up to it. With that distro it has an app called drivers. Open it up and choose suggested nvidia driver from the list and choose install. It will take care of the rest. Opensuse does not have an app like this that I have seen. I just installed it this morning and didn't see one. Im testing Gnome Ubuntu now for fun. It does have an nvidia driver section, you just have to know where to look.. type "additional drivers" search bar on gnome and open it up. It will find proprietary drivers for you and install them.