NTFS HDDs mounting as read only (using ntfs-3g)

Edit - Solution:

  • ntfsfix -d (on the drives that were stuck as read-only)
  • sudo Nautilus (to give proper permissions to all files and folders on the NTFS drives)

Thanks to everyone to helped!

Hi folks,

Just installed Ubuntu 18.04.1 LTS onto a second system (on its own SSD), which has four NTFS HDDs used for data only (no OS installed to them).

I placed entries into fstab for them, and they mount fine but are read only. Example fstab entry:

UUID=362899152898D4E9 /media/sammie/desk_t ntfs-3g defaults 0 0

Also tried adding uid and gid-1000, but to no avail.

Other details:

  • Fast boot was off in windows and in BIOS.
  • Hibernate was off, so windows did full and proper shutdowns.
  • mount returns the following:

/dev/sdc5 on /media/sammie/games type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)

/dev/sdd5 on /media/sammie/movies type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)

/dev/sdb1 on /media/sammie/desk_t type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)

/dev/sdb2 on /media/sammie/iso_images type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)

Incidentally, I have another system which is pretty much identical (installed Ubuntu, it had several NTFS drives, and they work perfectly, i.e., read and write access).

Any help would be greatly appreciated!

Instead of using defaults you can try specifying rw explicitely (defaults ads some other options too though), maybe the defaults are messed up for you.

Other then that, has the Partition been dismounted properly in Windows? You can try booting it up in windows, then unmounting it from the Disk Utility.

Good suggestion on trying to force rw in fstab, but so far everything I have tried yields the same end result.

I’m almost completely certain the partitions weren’t “dirty” when windows was shutdown for the last time. Fastboot is off, hibernate was disabled, and the system was fully shut down prior to the installation of Linux.

I’m going to try CHMOD -R 775 /dev/drive next. I may also give ntfs fix a whirl.

Thanks for the response.

Are you sure your user has permission to write to the mountpoint?

I think so, but I may not understand the question. I created the directories in /media as the user myself, then pointed the entries in fstab to them.

What I did notice was that everything on those four NTFS HDDs is owned by “root.”

I’m still quite a novice, so forgive me if was off topic in my response (and please advise).


  1. check your specific drive names: lsblk
  2. unmount them first with: /umount/sdX1
  3. make a folder (where you will mount): mkdir /run/media/username/FOLDER
    Seperate folder for each drive -all in same directory username
  4. Then,
    mount -t ntfs-3g /dev/sdX1 /run/media/username/FOLDER

run everything above as root
double check the lsblk output to see where drives are by-default mounted on your system. Change the above paths as appropriate (eg: it may be /media/username in your ubuntu,

The fstab thing is to automatically mount them. We will see that later. First this.

i am so confused, why do you say:

Fast boot was off in windows and in BIOS…Hibernate was off, so windows did full and proper shutdowns.

when you said you you are not even running windows??

That is normal as the NTFS-3G driver “pretends” as if every file was owned by root due to limitations in the user permissions on Linux.
Remember that on Windows you can have multiple users (or groups) with different levels of permissions on the same file. The same isn’t possible with the simple permissions on Linux (it is possible via ACL). So for all intents and purposes every file is owned by “root” to be able to access them.
Note also that when writing a file, that file will be owned by “other user” on windows (i.e. a non-existant user) and will have all permissions for everyone.

He only said there was no OS installed on them, he did not mention not using Windows at all

I realize my post wasn’t very clear. The system used to run Windows (hence the NTFS drives that are still in it), but no longer has Windows installed. :slight_smile:

This makes sense; thanks for pointing that out as it got me to re-think the issue.

In the beginning, i hope you did this:

Also, inside the VM Manager, when changing setting (say QXT >> Virtio) , try removing the whole thing & then “Add Hardware” with the required setting.

It magically works for me at times.
Any Update?

1 Like

I only saw your reply today, and thanks for this.

I did finally get it working with:

  • ntfsfix -d (to clear the dirty bit on all the drives).
  • sudo nautilus (re-did all permissions for all the folder recursively).

It was tough to track down that it was a dirty bit issue in the first place, but once that revelation hit, it was resolved.

1 Like

Alternatively, get rid of NTFS.

1 Like

That’s the long term plan, absolutely. These drives get moved more than occasionally into Windows computers for massive file sharing / transfers, hence the need to cling to NTFS at least short-term.

Not having played with Windows solutions to read Ext 4, and feeling nervous about file corruption (when using Windows extensions to read Ext 4), I’m going to keep it this way for the time being.

I usually just use a Fat32 or exFat partition thats about 30GB for transfer between OS’s if thats the sorta thing I’m running. But thats on significantly downgraded hardware than what I normally have. Its what I did back in my pentium 4 days. Kinda had to.

All the best.

1 Like

Between wifey and I, we capture enormous amounts of video for edit. It’s not professional, mostly for charity work. And as you know, video can balloon to ridiculous sizes. Between the two of us, 1 Gbit ethernet suffices, but if either one of us has to take some of the raw video or .raw out of the Canons, you can probably imagine how much data that is.

And the (unfortunately sad) truth of that is, all of our collaborators use Windows. :slight_smile: Hence the addiction to keeping those data drives NTFS. At least for the present.

Even if you won’t forgive the NTFS transgression, hopefully you will understand it … haha.

Edit: You know, what you said made me re-think things. We should probably each get a big HDD, like >=4TB, leave only that drive as NTFS, and use those for transporting files.

Appreciate your FAT32 comment, because that triggered a different way of looking at it. :brain:

1 Like

Gotta think outside the box. Translation layers are more than wine and dosbox, after all.

Not to be rude, but that was literally the first thing I asked about:

To which you replied

Sooooo… eh?

Yep, you called it. :slight_smile:

What threw me; I took one of the drives to another Linux system (one that wasn’t dirty obviously) and it mounted with r/w access, so it made me discard that theory initially.

You’re not being rude, but pointing out I should have just listened in the first place, haha.

Live and learn…

To be fair, that would have thrown me off a little as well… how does it mount on one system but not the other… probably some default configuration that ignores the dirty bit on one but not the other? Is there such a thing? I don’t know.

1 Like