No Wifi, Fresh Ubuntu Install - New Asus Laptop

Hi Guys,
Really hope someone can help.
Short history - windows user ‘finally’ switching to Linux, Today got my Asus M415DA laptop delivered, it’s fair basic but all i could afford… primary reason for getting it was to switch over to linux.
I’ve downloaded the latest Ubutnu to get my toes wet, unfortunately i don’t get wifi after the install. Windows 10 came installed and had Wifi installed fine so i think the hardware is ok. First install i didn’t select 3rd party drivers option, so thought that might had been the issue, just completed the second install with the 3rd party drivers option selected and still nothing.
The laptop doesn’t have an ethernet port on it, and I’ve done some googling but there’s not much out there generally about this specific model number and this issue, frustrating obviously! It’s literally the one bit i need working so i can start downloaded the stuff i need!
So that’s it, I’m hoping some Linux person here can help!
Many thanks in advance,

Sounds like your WiFi card doesn’t have a Linux driver. Swap the WiFi card for one that is confirmed working in Ubuntu (Intel is usually a safe bet)

Not sure if you already went through this otherwise gt it a try, it basically shows how to install a working driver.

thanks for the assists, I’ve followed the guide you mentioned, but i get an error when trying to load the cache from the image, I’ve tried several times but still get the error ‘sorry, Ubuntu 20.04 has experienced an internal error’.
I can confirm that i have a RTL8821CE wireless adapter.
I went on to google some remedies, but fell over on all of them (at least for the hour or so i tried) , some assume you have a LAN connection, others mention ‘get your laptop online through other means’… some are just double dutch to me lol…
I tried the github /tomaspinho/rtl8821ce. solution but i think that’s outdated for this version of Ubuntu.

So, I’m at a loss… is there really no option to get this card going? It appears to be at least a couple years old?
If all else fails I’ll try replacing it as suggested,

Hi again,
Bit of of an update - sometimes we can can’t see the wood through the trees i guess, but the solution was obviously to usb tether my phone to the laptop lol,
anyways, done that, now i can see the driver in software and updates, problem is now the following error when i try to install it:
pk-client-error-quark: The following packages have unmet dependencies: rtl8821cd-dkms: Depends: dkms (>= but is not going to be installed (268).

Can anyone put that into English for me pls?
Thanks again,

1 Like


I have a RTL8822BE and had to get a fairly recent kernel for it to work properly.

If you are running 20.04 you are probably on 5.4. Try installing linux-image-generic-hwe-20.04.

You error sound like some dependency issue. Remove the dkms module and try with the newer kernel.

Intel ax200 would be the best bet if the laptop supports other wifi chipsets. You can maybe get this one working but you’ll have to jump through hoops every time you install.

Broadcom chips are probably a safe bet too.

Easiest solution for a fresh install. Do either usb teather or wire into your wifi and reinstall. If you are new, you can select install 3rd party drivers and install updates during initial install of the OS and it will take care of all of it.

If you want to do the troubleshooting and the learning, lets start with a little more info: Can you open the terminal and run “sudo lspci”, take the result and paste it here.

Also would be a good idea, now that your online, do a full update of everything. I have a preference to update everything back to back due to laziness and can set is and walk away. You can remove the “&&”'s and run these commands individually or run as a single command in terminal: “sudo apt update && sudo apt upgrade --fix-missing -y && sudo apt dist-upgrade -y && sudo apt autoremove -y && sudo reboot now”

Heya All,

I really appreciate all the additional advice / feedback, although in a moment of frustration i decided to try Mint instead, still had the same wifi issue - but this time the github / driver fix worked first time without any fiddling! So now i actually have something up and running ill get my feet wet with Mint instead :slight_smile:

Thanks Again,

1 Like