No mice are working on one of my old pc's

Ok i was hooking up a pc i am selling to a friend,and none of the mice i tried with it worked,i tried a PS/2 ball mouse,it did nothing at all,i tried 2 old usb mice,1 did nothing at all,the other it lights on it cam on and the right click worked but nothing else,,and the i tried my razer deathadder and it also did nothing at all,but i tried my DA in a diff pc and it works fine,i never messed with the mouse setting in the bios,also the keyboard worked fine.

Also with the one mouse that did any thing at all i got an error message"USB device not recognized"

The weird thing is it was working fine before it took it over to his house.

What could be causing the problem?

it could be the motherboard,btw have you tried it on a different USB port that isnt on the motherboard? because the usb ports on your motherboard could have gone bad,or it could be a driver problem

 

I would make sure you have the newest drivers for the USB Ports

Ok, if no mice are recognised I would say reload the drivers.

Well i tried a a usb port on the back,anf on the front panel,also it was a fresh install of windows,and the ps2 mouse port did not work either. 

make sure that the bios has ps/2 enabled. and if its a combo ps2 port... manualy set it to mouse.

what version of winodws is it? you might need to install the usb mouse drivers for it.

Idk why i would need to enable ps/2 mouse cause i was using 1 a few weeks ago when i installed the fresh copy of windows 7.

All i did was unhook it after i installed windows,then set it off to the side,the 2 days ago i loaded inthe back of my truck(with a bunch of other stuff cause i am moving in with this friend)i was there setting it up for him when this happened,it is embaressing when you tell someone the pc is working great,and it does not when you get it to them.

it might have been damaged in the move.... thats very odd that ps2 and usb devices do not work.... have you tried a ps2 / usb keyboard?

 

edit: also, try in safe mode. if there was some windows auto install the wrong driver fuckup (which DOES happen) safe mode would load the backup drivers

when i finish moving i will try safe mode,also a PS/2 keyboard was used when testing the pc and it worked just fine,which is even more odd.

 

Try reloading drivers as all have stated. Also load into a linux live cd(linuxmint, ubuntu, etc.) and tell us if it works then. If so it must be a driver/bios issue.Try unistalling the drivers and then just reboot as Windows should load the defaults on its own.

PS. This doesn't happen to be an old Dell XPS by any chance?

 

No it is a custom built pc,also i will try the drivers and linux as soon as i can,and i will let you guys know.