Return to Level1Techs.com

No image in looking-glass client

Hi,

I have set up a Windows 10 guest on an Arch Linux host.

My problem is that I can’t see any image in the client, but I don’t get an error message either.

What I have done:

  • Windows 10 guest started with virsh
  • Connect with virt-viewer
  • Log in and start “looking-glass-host.exe” as admin (there is no response)
  • start looking-glass-client on the host -> virt-viewer terminates itself in this moment
  • Only the looking-glass logo appears.

Keyboard entries are successfully sent to the guest.

/dev/shm/looking-glass is 32 MB, seems to work.

looking-glass-client -k shows UPS: 0 FPS: 120

Output of looking-glass-client

[I]               main.c:996  | run                            | Looking Glass (B1-rc6-5-g8ad2d5f949+1)
[I]               main.c:997  | run                            | Locking Method: Atomic
[I]                egl.c:187  | egl_initialize                 | Double buffering is on
[I]                egl.c:201  | egl_initialize                 | Multsampling enabled, max samples: 4
[I]               main.c:902  | try_renderer                   | Using Renderer: EGL
[I]               main.c:1183 | run                            | Using Clipboard: X11
[I]              spice.c:197  | spice_connect                  | Remote: 127.0.0.1:5900
[I]                egl.c:447  | egl_render_startup             | Vendor  : Intel Open Source Technology Center
[I]                egl.c:448  | egl_render_startup             | Renderer: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) 
[I]                egl.c:449  | egl_render_startup             | Version : OpenGL ES 3.1 Mesa 19.3.4
[I]               main.c:1259 | run                            | Waiting for host to signal it's ready...
[I]              spice.c:409  | spice_on_common_read           | notify message: keyboard channel is insecure

When I run “tasklist” on the Windows command line as admin, there is no looking-glass-host.exe. Is this correct?

When I start “virt-viewer” again, the looking-glass-client terminates. Seems like they know about each other. :slight_smile:

Does anyone have an idea where I can look for the error?
Thanks!

You must not have a virtual video device attached, the host application can not function with it.

I am facing the exact same issue.
Running Manjaro with a 5700 XT has a host GPU and a Vega 64 as a Guest GPU the only thing I see is the looking glass logo when starting the client. Video is set from QXL to none.
It seems like looking glass host in Windows and Client on Linux do nto communicate with each other but I think I followed all the steps :frowning:

[I]               main.c:996  | run                            | Looking Glass (B1-rc6-5-g8ad2d5f949+1)
[I]               main.c:997  | run                            | Locking Method: Atomic
[W]               main.c:1031 | run                            | ================================================================================
[W]               main.c:1032 | run                            | WARNING: The FPS display causes microstutters, this is a known issue
[W]               main.c:1033 | run                            | ================================================================================
[I]                egl.c:187  | egl_initialize                 | Double buffering is on
[I]                egl.c:201  | egl_initialize                 | Multsampling enabled, max samples: 4
[I]               main.c:902  | try_renderer                   | Using Renderer: EGL
[I]               main.c:1183 | run                            | Using Clipboard: X11
[I]              spice.c:197  | spice_connect                  | Remote: 127.0.0.1:5900
[I]                egl.c:447  | egl_render_startup             | Vendor  : X.Org
[I]                egl.c:448  | egl_render_startup             | Renderer: AMD NAVI10 (DRM 3.36.0, 5.5.7-1-MANJARO, LLVM 9.0.1)
[I]                egl.c:449  | egl_render_startup             | Version : OpenGL ES 3.2 Mesa 20.0.0-rc1 (git-14c0d58c7f)
[I]               main.c:1259 | run                            | Waiting for host to signal it's ready...
[I]              spice.c:409  | spice_on_common_read           | notify message: keyboard channel is insecure
[E]              spice.c:1306 | spice_read_nl                  | remote end closd connection after 0 byte(s)
[E]              spice.c:320  | spice_on_common_read           | read failure
[E]              spice.c:642  | spice_on_inputs_channel_read   | read failure
[E]              spice.c:290  | spice_process                  | failed to perform read on inputs channel
[E]               main.c:394  | spiceThread                    | failed to process spice messages

No you are not, something is messing with your SPICE connection to the guest.

Please open a new thread about your issue.