Return to Level1Techs.com

No Audio Kubuntu 19.04, Z390 Aorus Master

helpdesk
#1

Hello I am using Z390 Aorus Master Motherboard and i just somehow installed kubuntu 19.04 to find that there is no audio please help. The board has ESS Sabre 9118 DAC which supports up to 32 bits of audio and Realtek ALC 1220. i have checked if the right hardware was selected to output audio and record from mic

1 Like

#2

What devices appear as potential audio outputs?

1 Like

#3

was audio working on Live Kubuntu ISO before installing?

check alsamixer to see if any hrardware audio levels need increasing or channels unmuting
First screen is usually defaulty for just Pulseaudio level controls
need to use F6 and select required audio card

0 Likes

#4

1st Built-in Audio Analog Stereo and 2nd HDA NVidia Digital Stereo HDMI 3

1 Like

#5

I couldn’t understand which bars to adjust in alsamixer there are so many. It says card is hda Intel pch, chip is alc1220 which I think is right by default. I will try to educate myself on alsamixer meanwhile. No sound during live boot

1 Like

#6

I know that when I got my Asus Xonar card, I had to run alsamixer and set the mode from surround to stereo for it to start working correctly.

1 Like

#7

i cannot find mode in alsamixer . i want to try to change it where is it?

1 Like

#8

I arrow over to < Analog Output > with the left/right keys and press the up/down keys and it switches between Stereo Headphones, Surround etc.
If you don’t see it, make sure you selected the correct sound card with F6, if you still don’t see it then your soundcard doesn’t support different output modes.

1 Like

#9

here is mine screen shot no such setting :frowning:

1 Like

#10

Try unmuting everything by going to it and pressing M so that they no longer say MM

2 Likes

#11

already done that

1 Like

#12

In your screenshot you still have things muted. Where are you plugging your speakers in?

1 Like

#13

agree about unmuting channels for ‘center’ and ‘lfe’
Pulseaudio tries to detect all surround sound profiles and may not be happy playing just in stereo if other channels are muted

alsamixer in terminal is not as user friendly as a full GUI mixer but do not usually need to check ALSA settings once they are all correct
There are GUI mixers qasmixer or gnome-alsamixer

speakers plugged in green socket on rear panel will use ‘Front’ in alsamixer

2 Likes

#14

i changed everything back to default. let me try that again wait. on my motherboard it say line out thats where i plugg my speakers

1 Like

#15

unmuting does not help whatsoever

1 Like

#16

@nikgnomic @SesameStreetThug i came back home and start my pc to find very low audio on kubuntu so i just tweak some bars in alsamixer and now perfect sound. i dont know what did it how it happened but i am so happy.

3 Likes

#17

cool it is working

for benefit of anyone else with similar issues, what settings in alsamixer are different now with sound working compared to your last screenshot ?

2 Likes

#18

my alsamixer settings are not being saved and sound works at random boots. that means not fixed completely

0 Likes

#19

use alsactl store

0 Likes

#20

sudo alsactl store to save ALSA settings
alsa restore to restore saved state
(ALSA settings may be changed by Pulseaudio when rebooting)

is system dual-booting with windows?
windows can cause problems after shutdown if fast startup option is not disabled

suggest you get alsa-info.sh diagnostic information when alsamixer is correct and audio is working.
then have known-good data for comparison to non-working system

1 Like