Return to Level1Techs.com

No audio in KVM with GPU Passtrhough?

#1

Some weeks ago i decided to finally make a kvm with gpu passtrhough, i just ended up with 2 issues: How do i get mouse and keyboard input and How do i get audio out of the vm. The first issue was solved with synergy, and the audio i only got it to work thanks to a dude that was in a level1 livestream.
He sent me this guide and i immediately started trying the options. Scream-pulse seemed to work, so i sicked with it. But 2 days ago, bot synergy and scream-pulse stoped working. Synergy was easily replaced with x2vnc, so it doesn’t need a fix, but scream-pulse still doesn’t work.
I tried the other 2 options on the doc, but the virt-viewer one caused this error, and with PulseAudio, virsh just refused to save the edits always, It always rolled back to how it was, no matter what. Also tried an ALSA alternative that i found on r/vfio (can’t find it rn, should have not used incognito.), but that one didn’t work either. (also, this)

Are any of this issues because of something im missing, or they no longer work in newer linux versions (arch btw, so kernel 5.1.4) or is this something that doesn’t make sense and should just work?
Just need either a fix for any or an alternative that will work almost guaranteed.

0 Likes