New PC build problem [SOLVED]

Hi,
I recently finished building my first PC, and when i powered it on it worked fine. It booted the BIOS with no problem. However when i try to install Windows 7 64-bit, it loads the files but then freezes on the splash screen and gives me a Blue Screen of Death. After searching the web I found a poster with a similar problem who was told the problem was probably with his RAM and to run a memtest86. I've ran the memTest86 for 8h and 30min with 5 passes and 0 Errors, so I guess that my RAM is fine? Did I damage my motherboard during the build? Is the problem with my hard disks? My GPU?

My specs:
Motherboard: Asus Z170-P D3
CPU: Intel i7-6700K
GPU: Asus GeForce GTX970 STRIX
RAM: 2x8 GB HyperX 1866MHz
CPU Cooling: Cooler Master Nepton 240M
Power Supply: Aurum S 600W
An SS 240GB, HDD 3TB 3.5 inch

Thanks in advance! :)

Have you tried a different installation medium? As far as I'm informed you can get a fresh iso off the Microsoft site.

Other than that: Get a random linux distro and try that. Ubuntu is pretty self-explanatory and somewhat fool-proof.

1 Like

If it freezes at the exact same time every time you try to install the OS, than it is VERY likely its either the installation source that is corrupt OR a corrupt boot drive. And in my experience I've had memtest86 pass for 12+ hours to fail in prime64 within 30 minutes and even the other way around once or twice.

Thanks for replying!

@Garfield
I tried both the "try ubuntu without installing it" and the install option, after the ubuntu splash screen my screen goes black with a text prompt on my monitor saying "Cannot display this video mode, change computer display input to [email protected]", so perhaps the GPU is at fault?

@neatoman
I've been booting form rather old usb so perhaps it is the boot drive at fault, however i tried booting on my laptop and it runs just fine.

Thanks!

Hm, that's odd. You could try the whole thing with your iGPU without the discrete graphics card. You could remove the GPU and try again. That would tell us if the GPU is at fault.

1 Like

Is your ram supported on here?
http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/Z170-P-D3/Z170-P_D3_DRAM_QVL.pdf

Make sure the power connectors are in all the way.
If that does not work try booting off of the mobo video out port.

I just built a new skylake system too and I had the same exact problem!!! I used the 6600k, but it's not a problem with the hardware, its a problem with windows 7 compatibility. You can try go into the BIOS and see if there is a legacy boot mode, though it did not work for me. The only thing that would work for me is to get a Windows 10 install disc and it worked perfectly for that.

Thanks for the replies! I'll try these methods and get back to you all!

You sure your ram is DDR4? Z170 uses DDR4, not DDR3, the lowest speed DDR4 at the moment is 2133mhz. You might want to check that.

z170 has boards that use ddr3 think of it as a stop gag intel put into place. not many boards support ddr3 but a few do. look at his board and it is a ddr3 board so he should be good.

1 Like

@Motorcycle_Max
It turns out that Windows 10 was indeed the answer, so massive thanks for that! However it doesn't seem to detect my HDD.

you're welcome! are you using a brand new HDD or one that previously had windows 7 on it?

I didn't know that they had made DDR3 boards yet, I know skylake does support it but I didn't know they had boards out yet that used it.

I managed to solve the problem. I just needed to tweak the partitions. Thanks for all the help!

Well if the topic is solved. I'm going to close the topic.