New mobo and cpu and still no boot

Just got a new motherboard and cpu (RMA) after having startup problems. When i start the computer the cpu led  flashes once and then the whole thing shuts down. All the fans and everything start up but then it just quits. I waited three weeks to get the new parts and now that thier is no boot still its very depressing. What do i do? I was thinking maybe the h60 if defective and the motherboard detects it and prevents overheat. idk? 


sabertooth 990fx r 2.0

Sorry I can't offer a more in depth answer, and I'm sure you have already checked for this, but when i took delivery of my pc I had the exact problem. Solution for me? I hadn't flipped the I/O switch on the power supply. 

Hope you get this fixed dude, have you tried running with just the basic components hooked up to the mobo? (Ram CPU etc?) 


Sorry dude that sucks, was worth the hail mary. 

Is the CPU is socketed correctly? Are you using compatible RAM? If you attach a speaker on to the board are there any BIOS beeps?

Try using the BIOS flash-back function to re-flash the BIOS.

this might sound daft but My PC did something similar to that when I first built it, turns out I forgot to plug in the CPU power connectors on the mobo, maybe check that its connected properly or even connected at all?

maybe a failing power supply?

Thats what i was thinking. im getting it tested this weekend and find out.