New linux x99 build

I am about to buy a nex x99 build. The purpose of the pc is to learn more about linux, try to get the windows virtual machine with hardware passthrough, try out LAG between this pc and my nas, use docker, and more. I have an older 2600k that does not support this virtualization so i thought it was time for an upgrade.
i put together a build at matx, because i am using the phanteks enthoo mini XL chassi. I am planning to put a secondary itx server at the top. i live in sweden by the way.
so here are the parts:

Intel Core i7-6800K, Socket-2011-3
ASUS X99-M WS/SE, Socket-2011-3
HyperX Savage DDR4 2400MHz 32GB
Samsung 950 PRO 512GB M.2 PCIe SSD
Corsair H110 Liquid cooler

the graphics card, is for now two 780, but will probably be replaced with one 1080 in the future. This build is mainly an upgrade for the cpu,ram and mb

is there anything specifically i should think of when i build a system for linux? are there any other things that is worth mentioning?

I would go for a used 5930K over a 6800K.

the broadwell-E parts don't oc well, or just get a Xeon.

if i go for a Xeon, which should i choose?
I heard Wendell and Logan talk about not buying Broadwell-e and instead going for xeon, but which one is equivalent of the 6800k?

an E5-XXXXv4 I think.

I think you can even get the 10 core Xeon for $700 or so? don't quote me on this.

You know about the E5 2670s flooding ebay?

I don't think you'll be able to easily do Hardware pass-through to Windows Virtual machine with a gtx 780/1080/any other Nvidia gpu. Needs to be an AMD gpu.

I did not know this and I have always been curious about maybe doing a Linux setup.

Why can't you use a Nvidia GPU Mr_Plutonium?

You can do pass through with NVidia gpus. You just have to put an option in that tricks the gpu into thinking it's not being used by a virtual machine.

I'd stick with haswell-e for at least the next 6 months, since the haswell-e x chips are largely binned by Intel now.

I'm basing this off of Wendell's thread and video on Hardware Passthrough to Windows on Arch.

I've never tried passthrough with nvidia hardware before.

Zero phase is correct. However nvidia may escalate their antisocial behavior any time

1 Like

so i brought the pc with the 6800k, mostly because i could get it fairly cheap.

I have now built the pc.
Before starting the pc i tried the bios flashback and followed the video wendell made a while back.

but i dont think it worked. pressed the button and nothing happen.
the flash-drive is formatted in fat32, named the file accordingly to the website, inserted it in the correct port.

so i tested booting it. it starts but gets stuck on boot code 53 and shuts down. Googled it and it is apparently some problem with the memory. I tried inserting both stick, one at at time in all slots but still the same.

So do i have a problem with the UEFI or the memory?