New Build won't boot

Hi I have spent all day building this new pc - my first in about 10 years (what possessed me)…well actually my ROG laptop died.
Anyway Thermatake V1 case, Asus strik x470-i motherboard, Ryzen 5 3400G, Gigabyte Radeon RX570, GameMax 850w psu, Ballistix Sport 3200 8gb x 2.
All built -c fans and lights all working beautifully - but nothing else? monitor pops up with no signal, tried connecting a keyboard and pressing DEL - nothing, have taken it apart and checked everything numerous times and put it back together bit by bit and tested. Orange q leds indicate its VRAm issue,. I’ve removed ram, tried one , two but no difference. I am now sitting looking at a very expensive and pretty piece of art - please help me figure this out

Get latest firmware for your motherboard.

You might have to contact AMD for the upgrade kit/loaner cpu

my understanding that this was ready out of the box for 2nd gen ryzen?

3400G is 3rd gen

It still uses the Zen+ cores, but it is overal working based on the Ryzen 3000 design, so you need to update the UEFI to be able to run it.
That is the genius of the entire ZEN/Ryzen design - you can mix and match and there is absolutely no problem…

Yeah luckaly he has a board that supports bios flashback.
Otherwise yeah…

One of the reasons why i generally not recommend people to buy a X470 board,
for a Ryzen Zen2 cpu, when they start with an entire new build.
Because you are going to need to update the bios.
And not every board has a bios flashback feature.
Next to that pci-e4/3 quirks, that you might encounter.


Take out the rx570 and try it on the iGPU
Then find igpu disable thingy in bios
turn off
Throw GPU back in
Plug monitor into GPU
Hit On switch
Hope this helps

Old Kavari user so a bit rusty but you get the idea


?? Tried without rx570. Input thingy in bios…i’ll Be honest not very knowledgeable on bios on motherboard so may need a little more help on what that means please

Box says 2nd gen but all my research said 3rd so got a little confused…i’m Reluctant to pay for a compatible cpu as it will have no use afterwards - contacted AMD and waiting for a response. Thanks for that advice :grinning:

1 Like

3000 is zen 2 but third gen. You should have bios flashback which means you can download the bios update on another machine and update via USB drive. No need for the CPU from AMD.

Primary video device
GFX will be the APU outputing through the MB port
PCIE video will be for the rx570

When I decided to build another PC I found things had changed since the 486 days, finnally I had to google almost every setting and part to figure out what was what. It is a pain in the neck

On mine the default was the GFX which meant the only way to get to the bios screen was to plug the monitor into the MB. It will also confirm the mb and cpu are good

1 Like

Thanks I will try this…will it read the usb?

There should be a usb port that is surrounded by a white rectangle on the i/o shield. That is the port for USB flash back. Read the manual to be sure how to do it.

Looking into your board specifically, you dont have flashback, you have the crashfree bios 3. You cant use that to update so your only option is to get another gen 1 or 2 ryzen cpu either from AMD or borrow from someone to flash with.

or get a board with that flashback capability like the msi b450 tomahawk

thanks for the advice guys…just spent an hour finding and downloading
then coudn’t find usb flashback lol…
so back to plan a - still waiting for AMD to get back to me.

1 Like

yeah, unfortunately the crashfree bios thing really only helps if you have a bad flash or something.

bios flashback is different in that you can just hit a button and flash a bios from a USB drive at any time.

so I have purchased a new CPU A6-9500 and my new build works - but now still have a problem.
I have usb fat32 with the x47-.cap on it - but can’t get into bios…it boots straight into windows 10. I have tried the advanced screen via windows but no uefi option and when i try to boot into safe mode I have no display and then after pressing some keys it goes back to windows…please help