Return to Level1Techs.com

New build only half the ram shows up in OS

#1

Hi all, I finished up a new build last week and have been getting Arch all configured. I noticed last night that although the BIOS is seeing all 32G of ram, Arch is only seeing 16G (using (2) 16G sticks). I tried booting into and Ubuntu live cd as well as Memtest86 and those both only show 16G as well. For sanity I also ran uname -a to be sure I installed 64 bit. All good there. I also updated the BIOS and the system boots fine on either stick.

Any help greatly appreciated.

X470 Asrock Taichi Ultimate
Ryzen 2700x
32G G.Skill Trident Z (2x 16G)

0 Likes

32GB of ram installed but 15.9 useable?
#2

I just noticed the BIOS said it was running in single channel mode. So I did some more experiments. I tried booting with just one stick of ram. I moved to a different slot each time. It won’t boot with wither of the sticks in B_1 or B_2 only. I put both sticks into the A slots and now it boots and shows 32G ram. I 'm running memtest now just to be thorough but should I be looking for a bent pin on the cpu or is the motherboard toast?

0 Likes

#3

so the ram shows up now? could have just not been seated correctly (Fully)

0 Likes

#4

All the ram shows up in the OS if in slots A1 and A2. Any stick in B1 or B2 will show in the BIOS (and bios states it is running in single channel) but not to the OS.

0 Likes

#5

Assuming you updated bios? Reseated CPU already? Also assuming mobo say a1 and b1 for dual channel?

A2B2 show up?

0 Likes

#6

Updated BIOS

Manual says A2 B2 for dual channel. Both sticks show up in BIOS but only one in OS.

Going to check CPU for bent pins and reseat as soon as I can I guess. Its got a custom hard tube loop so I’m not excited about it.

0 Likes

#7

So I pulled out the CPU tonight. No bent pins but a handful (about 7 or 8) of the pins looked dirty when I looked at them with 20x magnification. It appeared to be thermal paste maybe? Not sure how I managed that f-up. Anyway, is it possible this could be the problem? Going to clean up the CPU and cross my fingers.

0 Likes

#8

Sounds like a bad board. Im going to suggest anything that wasnt explicitly mentioned here as already attempted.

  1. Run optimized defaults only form bios. No XMP fancy stuff.
  2. Test each stick individually in memtest

Sounds like the B half of the slots are bad on the board.

0 Likes

#9

It could be that the thermal paste on pins is problematic. Most modern thermal pastes are supposed to be non conductive (to prevent possible shorts when pushed out the sides). But that also means that if the paste is covering the bridge between two contacts that are supposed to be contacting, it won’t allow contact. possibly.

0 Likes

#10

I have done these two (well three things) with no luck. I believe you are right about the board. Thanks for the input. I ordered another board to test out with my cpu and ram to see if that is it.

0 Likes

#11

Yes, from what I have been able to find, it sounds like the paste (although not good) is probably not the issue. Thanks

1 Like

#12

Just an update for you folks that contributed. Grabbed a new mobo and booted it up. Boots fine with ram in either B_1 or B_2 and when I have two sticks in bios says 32g in dual channel mode. Looks good so far. Will start tearing apart the old build. Fingers crossed but it sure looks like the mobo was the issue.

2 Likes

#13

Okay final update. Replaced mobo and all is good. I really didn’t want to tear it all apart again but in hindsight it was better because I decided to replace all the rgb led strips in the water blocks with white ones and turned off the “gpu tach” leds on the 2 vega 64s (you can’t get to the dip switch with the ek backplates on and not only are the leds annoying one was switched to red and the other card to blue). Those items were already making my ocd go crazy.

Thanks again for the help and direction.

0 Likes