Return to Level1Techs.com

New 5700XT, x570 system wont get past boot in Manjaro

#1

I bought a new system a couple of days ago, a lovely asrock taichi x570 with an 3700 in it and as a GPU an 5700 XT.

Thought to myself, “now is the time to run linux on metal and virtualize all the things” and can buy bleeding edge because Linux is awesome.

I Tried to install Manjaro and failed horribly at it. I never got it to boot properly. I suspect it might be a driver issue, specifically a display issue.

Does anyone have any suggestions on how to get it to boot properly?

0 Likes

#2

I don’t believe Manjaro is on 5.2 so you’re probably safe there. Next would be turning off legacy/csm mode as another thread suggests a GPU doesn’t work with 16x PCIe off the chipset while in legacy mode (irrelevant if that’s not the case tho).

Could you not even run the live cd or did it fail to boot after install? Details :wink:

0 Likes

#3

Initially i used the stable manjaro and that printed out the systemd(?) messages during boot with all failed.

After searching a bit around i found out through a forum post that the RC5 does work.
That got me past the systemd and gave me all OK.
Then it got stuck with as last message “Started TLP system startup/shutdown”.

0 Likes

#4

Try booting something on a older kernel as a test?

0 Likes

#5

Well Manjaro stable is at 4.19 I believe? I’d try Pop OS or something else that is on 5.0 to 5.1. I can’t confirm what kernel RC5 is on atm but 5.2 isn’t good for VFIO either if that was something you wanted to try. There is a regression that causes some VM stability issues that I don’t think has been patched yet. Just mentioning it as you said virtualize everything, but not sure if that included Windows.

edit err… apparently Manjaro stable is at 5.3 rc atm? Strange it’s been a week or so but I swear my manjaro was at 4.19 before I wiped it. I could be getting it confused with my other linux box tho.

0 Likes

#6

Depending on the BIOS firmware… that systemd bug might be an issue

Then theres the other issue of amdgpu (in kernel 5.0 / 5.1 / 5.2? ) not being ready for radeon 5700 yet.

0 Likes

#7

oO; I didn’t know about the 5700 bit. Hmmm… Doesn’t sound like there are a lot of good options. Something bleeding edge that starts with a minimal installer? You might try the Arch community? That might be a tall order though if you’ve never installed linux without a LiveCD/Gui installer.

I’m guessing someone might be able to come with a better idea?

0 Likes

#8

I have installed arch before so that should not be an issue :slight_smile:

Its indeed the issue of 2 bleeding edge devices

0 Likes

#9

I have a Gigabyte X570-I Aorus Pro Wifi motherboard, 3700X, 16GB 3600MHz sdram, Gigabyte Aorus NVME Gen4 2tb M.2 and a Radeon VII. I put Manjaro on a usb and it would not post on this system, Ubuntu 19.04 worked but wifi wasn’t recognized and wouldn’t work. Elementary OS Juno failed to boot, Kubuntu 19.04 booted and installed fine with wifi working out of the box. I settled on Salient OS and am still in the process of installing software and my favorite games.

1 Like

#10

I am having the same problem. My hardware is a little different (MSI MPG X570 Gaming Pro Carbon Wifi, 3900x and ASUS RX 5700 XT) but it’s the same symptom that I can’t get past the boot of the installer. I have tried the following OSes and failed to get it installed with any:

Manjaro KDE 18.04, 18.1.0-RC8
Arch 2019.01.01 and 2019.08.01
Ubuntu 18.04.2, 18.04.3 and 19.04
Mint 19.2
PopOS 18.04 and 19.04
Debian 9.9.0 and 10.0.0
Gentoo
OpenSUSE Tumbleweed
Fedora 30

I did see a post somewhere that mentioned FreeBSD 12 worked out of the box and it did successfully install for me as well.

I have updated the BIOS to the latest 7B93v124(Beta version) and tried the installations again to no avail.

The errors I get in almost all of the attempts is related to AHCI not recognized. Each installer tries to reset the controller but can’t see any SATA drives (apparently). I’m not clear on this though because as an example with some of the more verbose installers I could see the drives listed but still got the error.

I’m not a complete noob but my previous Linux installs have gone (maybe fortunately or unfortunately) pretty smooth.

I am thinking I may just have to wait until a different BIOS becomes available or start learning FreeBSD.

Just wanted to add my experience in case it helps and see if anyone has any advice.

Thanks,

0 Likes

#11

Pop!_OS 18.04 is good. However 19.04 doesn’t work for me (same hardware 3700x x570 5700XT) I have the world’s worst screen tearing with 19.04 that I can’t seem to solve.

0 Likes

#12

You guys tried Solus?

I only used it with older hardware, but should be good. It’s rolling release so maybe you get some of that bleeding edge

0 Likes

#13

I did try Solus now but I’m still seeing the same errors there: AHCI Controller Unavailable.

I am really not sure why FreeBSD works but nothing else seems to.

0 Likes

#14

The main issue for me was installing Navi firmware prior to install.

2 Likes

#15

If you are on a 5.3 kernel, you need the firmware form here:
https://people.freedesktop.org/~agd5f/radeon_ucode/navi10/
Just put it into /lib/firmware/amdgpu
Otherwise the amdgpu kernel module will crash leading to a black screen.

0 Likes

#16

I’ve just received my order of the new AMD RX 5700XT and I’m now too in this predicament, is there any way that we could use Fedora 31 beta? If so where would i download it from?

It will come with the kernel 5.3 and i know Fedora have beta meeting this Thursday.

0 Likes

#17

how did you get past that part?

0 Likes

#18

I used a different GPU initially.

1 Like