Return to Level1Techs.com

Never ending unmet dependencies for WineHQ on Ubuntu 18.04 LTS


#1

I’ve finally made the jump from removing Windows from my life, but alas I do still need some Windows-only applications. I’ve been trying to install Wine on my Ryzen 5 1500x system running Ubuntu 18.04 LTS, but there are just gigantic rabbit holes of unmet dependencies.
When I try running sudo apt-get install --install-recommends winehq-stable, I am shown this: The following packages have unmet dependencies: winehq-stable : Depends: wine-stable (= 3.0.3~cosmic) E: Unable to correct problems, you have held broken packages.

So, then I figured I’d run sudo apt-get install --install-recommends wine-stable to install the dependency. Then wine-stable has a dependency that needs installed: wine-stable-i386. The list goes on and on forever, and I’m kinda at a loss as to what to do.

Note: Pre-install I ran sudo apt-get install --install-recommends wine-stable & wget -qO- https://dl.winehq.org/wine-builds/Release.key | sudo apt-key add - & sudo apt-add-repository 'deb http://dl.winehq.org/wine-builds/ubuntu/ artful main' as multiple guides instructed.


#2

For some reason it is making mention of Cosmic, and the note at the end mentions Artful (end of life) and you are on Bionic. It looks like Bionic exists in ‘http://dl.winehq.org/wine-builds/ubuntu/’ , so maybe you can change that last part to bionic and get things squared away. It would likely require removing the artful repository first.


#3

Just install Lutris. It should fix the dependency issues.

https://lutris.net/


#4

I removed the Artful repository and added the Bionic repository, but I still get the same results.


#5

sudo apt -yf install ?


#6

Installing Lutris did not fix the dependency issues.


#7

I tried sudo apt -yf install winehq-stable but i still run into the same dependency issues.


#8

Not winehq, the above command by itself

Then try the package again


#9

Oh whoops lol.

I still get the same result. I ran sudo apt -yf install and sudo apt-get install --install-recommends winehq-stable


#10

Did you run apt update every time you altered the repository list?


#11

Btw, wine should be provided by the ubuntu repository. I would recommend removing the winehq repository altogether and check whether wine installs then. Try the winehq repo later when you are sure, that you need a more recent version.


#12

Removing the alternate repositories and just using the Ubuntu repository worked! Thank you very much!


#13

Glad that you got wine running. Here an other bonus tip:
For 32 bit applications you want to run 32 bit wine, which i think is not installed by default, so its highly encouraged to install the wine32 package also:

sudo dpkg --add-architecture i386
sudo apt update
sudo apt install wine32

#14

today I learned. . .

Thanks for letting us know what worked!


#15

How do you remove the winehq repository and install from the ubuntu repository?


#16

Hey sorry for the noobish question but how would I go about removing the repositories?


#17

#18

Hey, u can remove repository from software & Updates > Other Software…there u will see the default repository listed at the top… Hope this helped