Network Speed Detected Wrong

Hey guys,

Havent been on in a while, but I just came back to linux due to worries about security within windows. I am having issues, as my network speed is coming up as 100Mb, yet it is a gig adapter, connected to a gig switch, with a 5e cable. I was getting gig speeds in windows prior to the install.

As a note, I am running Pop OS 20.04.

Any ideas?

I just tried to force it to gigabit with ethtool and it disconnected, and would not do anything till i changed it back to 100.

How long is your total 5e run?

What model NIC are you using?

its a realtek adapter, I had to play with my switch and i am able to get gig speeds right now, but i had to swap it to a gig only port. I still get gig speeds on the other ports on windows machines though.

What about gig connection with Windows on your machine? Or if you spin up a live Linux environment do you get gigabit connection or it switches to 100Mbit if you let the NIC negotiate the speed?

I get the 100MBit on a live boot as well.