Network shares under ubuntu

In Ubuntu-Gnome 17.04, I have a second internal spinning drive were i want to share files from. I have enabled the share option under the folder properties. When i go to another machine it is requiring a password.

How do i remove that requirement or set that password?

Have you tried your root password?

Im not familiar with unity so this might not be that helpful. In 17.10 they use GNOME which has options for share ING your public folder and setting on or off a password.

For sharing other folders you might prefer to use NFS, it’s not really to hard to set up. If you want to access it through windows (you can with NFS but it’s a bit more of a pain) you can use samba instead. Small configuration to set it up but it also works well.

There password your getting asked for currently should be your users password I think. There might have been a guest access checkbox when you created the share?

Haven’t done network shares much, but prolly the issue is just DAC ownership. If you chmod the drive to allow anyone to read and write, and execute possibly, might solve the issue.
Just sharing a directory allows external access to it, but ownership might stay unchanged.

@Eden is correct. When you share the directory is will require your username and password.

Ownership of 777 is horrible security practice.

The directory permission should be set to 775, and file(s) permissions should be set to 664. If the file is world-writable then it wouldn’t require his password to access it. But being world-writable is bad.

So OP,

chmod 775 /path/to/directory
chmod 664 /path/to/directory/file



There are several directories and files, could i just run:

chmod 775 -R /path/to/directory

In terminal
Make the username same as your PC.

sudo smbpasswd -a <user_name>

Create a password -> enjoy.

1 Like