Network Issues Fedora 31

I am having a strange issue with my computer where websites do not seem to be loading properly. When ever I try to load a website I get the connection is not private error in chrome and firefox. I know that my internet is working because I can run dnf update and download packages through terminal. If I go into my windows virtual machine or boot directly into windows website load fine. What can I do to fix this issue?

wifi or wired?

Wired connection.

Can you post a screenshot of the error in both Chrome and Firefox?

what DNS?

I have it set to automatic in my setting and it set it to and

never heard of that dns server…

have you tried or or

I just tried switching my dns over to those servers and I still get the same error.

I just booted into a live USB of fedora and the internet works with the and dns servers.

Sounds like you have some crud doing a MiTM on you. Did you install any “security” software that’s doing traffic analysis?

No I’ve just been been messing around with pcie passthrough. My internet was working fine until last night when it stopped working. Should I just reinstall fedora?

i vote yes

That and the other one are Comcast default DNS. I use them for my upstream DNS and have not had a problem like this. I don’t think the DNS is to blame.

It’s vaguely possible the system did not get the root certificate stores installed. I have never seen it happen, but if it did all the SSL/TLS certificates would fail like that.

1 Like