Netgear A6210 does not work in linux

Hey,
I want to use my A6210 adapter in my Kali Linux VM. I insert my adapter into the VM but it is not recognised. I tried installing this:


It installs but it does absolutely nothing. Linux does not recognise my adapter. But it works perfectly on windows.
What am I doing wrong? I can insert it into my Windows VMs fine, just not my Kali Linux.

What instructions did you follow?

The DKMS instructions should work. Is this a USB or PCIe device?

What VM host are you using?

I followed the intructions on the GitHub page.
It is a USB device. There is no official driver but people have had luck using that GitHub driver.
I am using Windows 10 on my PC, and Kali Linux in VMware Workstation.
I don’t know what DKMS is? Isn’t that used for if I’m upgrading Kali Linux?

If you’re running into this problem, you might want to brush up on Linux basics before embarking on the Kali journey.

That said, let’s get this problem solved.

DKMS stands for Dynamic Kernel Module Support. It’s one way to install “drivers” or modules into the kernel. If you look at the bottom of the readme of the github page you linked, it’ll show the instructions for DKMS.

Official drivers don’t really matter that much. I’m just asking because PCIe and USB are two very different devices.

can you share the output of lsusb within the vm? Let’s make sure it’s actually showing up.

1 Like
sudo: dkms: command not found

I get that error when trying to add it to DKMS

And yes it appears in my terminal:
Bus 002 Device 002: ID 0846:9053 NetGear, Inc. Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub Bus 001 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
One thing I have noticied though, even if I disconnect my device from the virtual machine, it is still listed in lsusb

:confused:

sudo apt install dkms

That should fix your issue.


Use three backticks (`) to do a block quote of code for your terminal output.

That might be a problem.

[email protected]:~$  sudo dkms install netgear-a6210/2.5.0   

Creating symlink /var/lib/dkms/netgear-a6210/2.5.0/source ->
             /usr/src/netgear-a6210-2.5.0

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...(bad exit status: 2)
make -j2 KERNELRELEASE=4.19.0-kali3-amd64.............
cleaning build area...(bad exit status: 2)

DKMS: build completed.

mt7662u_sta.ko:
Running module version sanity check.

Good news! Module version 3.0.0.1 for mt7662u_sta.ko
exactly matches what is already found in kernel 4.19.0-kali3-amd64.
DKMS will not replace this module.
You may override by specifying --force.

depmod...

My command has been stuck here for a few minutes. Should I ctrl+c or leave it running?

It tends to do that for a bit.

So yes.

I left it running overnight, it is still at the same stage…

What should I do?

@yotoprules I know the advice I am going to give you won’t help with your problem, but I thought I would recommend a book I found useful understanding Linux. The Linux Command Line by William E. Shotts, Jr.