Need some support with a "ViBeRaTiNg" screen on my laptop

I have a problem with my laptop display, it flickers in a way that makes the screen look like it vibrating. This problem has been going on since Ubuntu 20.04… and it isn’t just a Ubuntu problem, it happens with 5 other distros.

I would like to move away from Windows 10 because I don’t like 11… But, this problem is a deal breaker as I want one distro on all 3 of my PCs (Desktop, laptop, and Surface Pro 2). I am not the only one suffering this problem either, several other people are experiencing this problem but there is no answer for it.

Specs of laptop: Gigabyte P37X v4

Intel Core i7-5700HQ Intel HD 5700 and Nvidia GTX 980m 8GB of vram

I run the display with igpu and dedicated GPU and still have the same problem…I’ve tried changing all display settings to no avail… This problem seems to be more of a kernel problem.

For a visual aid on what the problem is, here is the screen recorded from my phone:


I am willing to work with anything or anyone to get this problem fixed.

Thank you for your time and understanding, Hex_Dex

1 Like

Hi, welcome.

I agree this is not normal, not even a usual problem, it “smells” like an Intel display driver issue where it’s pushing some clock rate somewhere in the pipeline too hard for the hardware you have, or it’s initializing some overdrive-like thing wrongly.

Is it present on all resolutions?

Is this shimmering, still present after you’ve updated everything on the system?
(I realize it’s hard to work with a computer like that, asking?)

What distros have you tried so far?
(trying to get a sense of kernel/driver versions age range)

Most debugging is basically just hunting for regressions, which is essentially a process of narrowing down the range of variables between a thing that kind of works, but is not ideal, and a thing that is otherwise ideal but has the one thing broken.

In this case, I’d maybe give Arch Linux a try (not Manjaro), but old school install, one piece at a time following the wiki instructions, not because it may or may not be ideal as a daily driver distro, or because it’d make your system work or not, but because the distro kernel and drivers are very close to head/upstream and the wiki has a ton of contributors and separate steps for setting up separate things that might help you narrow down the issue and/or a fix… after which, once you know what’s causing the shimmering, you can hopefully transplant the fix to whatever distro you choose.

(yes I realize it’s perhaps not the most “easy mode” distro for a new Linux user, and it’d take tons of time and might not help, that’s truly unfortunate :frowning: ).

Sorry for not getting back to you sooner, been dealing with another laptop problem (touch pad causing battery to run flat) and Covid… and wasn’t expecting a response to this glares at AskUbuntu

let me answer your questions,

Distros used to solve problem: Ubuntu and several flavors of it, Pop-Os!, Linux Mint, Fedora, and Manjaro… problem doesn’t show up in live mode…does when fully updated…

Resolution: It shows up in all resolutions, the panel on my laptop only outputs in 60hz

Update?: I have just updated to the current version of linux as of writing and still have problems, this problem showed up after the 20.04 update to ALL LINUX

Intel?: Don’t think so, as my laptop has a iGPU and a Nvidia GeForce GTX 980m (8GB vram). When I used Pop_Os! I force the system to run of the Nvidia card… NO CHANGE…

I understand that this debugging issue will take time and A LOT of trial and error, but that is the only way at times… I’m ok with this.

My thoughts, this seems to be something bigger… like a driver… or an error with the kernel… not 100% on this, but Windows 10 isn’t experiencing this issue (I know different ball park, but it isn’t physical damage to display)

Let me know if you want me to do anything/ do anything to help solve this issue…

OK… This is weird… after updating the laptop when I made the post, I shut down and made dinner, came back, boot up… and the vibrating is GONE!!!

I don’t know what happened to fix this… I am not looking gift horse in mouth… this just happens sometime…

I hope that this problem is on all versions/ distros as I am still looking for one that I like… currently on Ubuntu Studio, I can tolerate it… but I am worried that I will be to heavy for the Surface Pro 2.

Looking for a distro that is good for the Surface Pro 2 (Drawing/picture editing and music creation with tracker programs) as well as capable to work good with games and NVIDIA GPUs (laptop - GTX 980m Desktop - RTX 2070). VR in Linux is still far off so I will keep Windows 10 for that.

Thanks for the help… this is very nice to know that there is a place that is willing to help with any problem.