Need help with Open VPN & SSL server on FreeNAS

So I'm trying to set up an Open VPN server on FreeNAS. I've mostly been following this guide through the process. The problem with the guide is that it's for an earlier form of Easy-rsa. The new version doesn't source the vars file, and instead is mostly an all-in-one script. I've mostly finagled my through these problems, but I ran into a bug when I was building the certificates. This was the output:

[email protected]_1:/openvpn/easy-rsa # easyrsa build-ca

Note: using Easy-RSA configuration from: /usr/local/share/easy-rsa/vars

Easy-RSA error:

The OpenSSL config file cannot be found.
Expected location: /usr/local/share/easy-rsa/openssl-1.0.cnf
[email protected]_1:/openvpn/easy-rsa #

Sooooo I went to /usr/local/share/easy-rsa/ and "openssl-1.0.cnf" wasnt there. I got the file from here and put it in the directory. After running the command again, I got the same error. I opened the easyrsa file and this was the only reference to "openssl-1.0.cnf".

# Detect openssl config, preferring EASYRSA_PKI over EASYRSA
if [ -f "$EASYRSA_PKI/openssl-1.0.cnf" ]; then
	set_var EASYRSA_SSL_CONF	"$EASYRSA_PKI/openssl-1.0.cnf"
else	set_var EASYRSA_SSL_CONF	"$EASYRSA/openssl-1.0.cnf"
fi

That should run just fine because of the "$EASYRSA/openssl-1.0.cnf", but it doesn't. So I checked google for a solution. Most people had this error running in windows (because directories are structured differently) and Ubuntu. A lot of people, like these, are referencing a 'whichopensslcnf' file. That also isn't in my directory (as seen here) (Had to edit format, HTML is being a butt at indenting).

[email protected]_1:/usr/local/share/easy-rsa # ls
easyrsa.real
vars
x509-types
oppenssl-1.0.cnf
vars.example
[email protected]_1:/usr/local/share/easy-rsa #

I'm super stuck now and I don't want to drop this project. Does anybody have any suggestions or ideas?