Need help with bricked Samsung Galaxy S3 I9305 LTE

I really need help with this weird problem I am having, I just flashed custom ROM (ArchiDroid 2.4.5) with TWRP recovery did not get any errors what so ever, but when I start up the phone it does not go past the Samsung/Custom logo.

I have already tried flashing other ROMs like Carbon, LiquidSmooth etc even the Samsung s original ROM installs fine but wont boot. Tried flashing same roms with clockworkmod and even with odin but the end result is the same.

I currently can get access to boot-loader mode and recovery mode any ideas how i could be able to unbrick my phone

I assume you have been waiting and then turned it off for another try? First boot up after a flash takes a while several minutes some times. Just turn it on and let it sit for a while the Custom boot logo will do its thing and it should carry on after. 

On the other hand you could have boot loops, they are also not hard to fix but worth trying the other solution first, if that is a no go report back.

Yeah did couple of boots with each of the images waited around 10 minutes before retry, and I have tried boot loop fixes but they basically just tell me to install Samsung's ROM so if you have any other method please share it.

Get a ROM that is for sure for your model of phone, AT&T, Verizon, International, it makes a difference. Then Back up your existing ROM (probably too late for this) and factory reset the phone. Flash the custom ROM and then wipe all the caches, realistically you only need to do the Dalvik but may as well nuke the thing to be sure.

I have tried that, but just to be sure tested again same end result and this time double checked every step.


I had this crazy idea if someone has recovery image for Samsung Galaxy S3 I9305 4G could you upload it for me so I could try flashing that through recovery mode.