Need help with AB350 Pro4 (P4.90) + Ryzen 5 2600 that does not POST

Hi all, long time PC builder, first time poster. This is my first bad build, so maybe somebody can help me sort this out, as I’m out of ideas.

I recently purchased this hardware with the intent of building a home VM lab that will serve as a pfSense router, file server, VPN host, home automation server, etc.

  • ASRock - AB350 Pro4 ATX AM4 Motherboard
  • AMD - Ryzen 5 2600
  • AMD - A6-9500 (for bios Upgrade)
  • 2x Kingston - ValueRAM 16GB (1 x 16GB) DDR4-2400 Memory
  • Samsung - 970 Evo 500GB M.2-2280 Solid State Drive
  • EVGA - 600B 600W 80+ Bronze Certified ATX Power Supply
  • Nanoxia - Deep Silence 2 ATX Mid Tower Case

I placed the A6-9500 on the mobo, connected HDMI, booted to BIOS, and upgraded from P4.60 to P4.90 to gain support for the Ryzen 2600. The flash was successful, the BIOS now reads P4.90, and I rebooted the machine several times.

I then placed the Ryzen 2600 chip on the mobo, and it would not send anything to the display. I found that some people have unusually long POST times with this chip, so I let it sit for 5 minutes. After several tries and no display, I unplugged, swapped the CMOS reset jumper, waited a minute, swapped it back, and tried again. No luck.

Thinking that perhaps it’s a RAM compatibility issue, I swapped out the ECC RAM (which is widely reported as working) with a single stick of Corsair DDR4 from another machine, Still no luck.

I placed the A6-9500 back in the mobo and it POST’d just fine. I confirmed the BIOS is P4.90 and double checked that Ryzen 2000+ support was introduced in P4.70+.

With great frustration, I concluded the CPU must be dead, as I had just seen the motherboard POST with another CPU and the same RAM, so I returned the CPU to Amazon as DOA.

Today, I received a replacement 2600, and sure enough, it’s the same result. Sorry Amazon and AMD.

As I see it, there’s no way I’ve received two bad chips. There’s no way it’s a bad motherboard (because it does POST with the A6-9500). There’s also (almost?) no way it’s bad RAM when it’s widely reported as compatible and I’ve tried alternate DDR4.

I don’t know what to do :sob:

Should I return the AB350 Pro4 and buy an expensive X370 or X470 even though I don’t need the features and have no intention of overclocking? Has anyone seen a board work for one CPU and not work for another CPU? I don’t know where to go from here.

Help me, Level1Techs :heart:


The ryzen 2600 does not have an integrated gpu, where the APU you bought does. You need an external gpu to get video, because there’s no integrated GPU.

solution: get a gpu



Thank you.