NEED HELP! windows 8.1 BSoD kernel_security_check_failure LOTS of troubleshooting got nowhere!

Hey there. I have been battling a problem with my gaming PC since I got more RAM, but it is not the RAM. I built this machine in jan 2012, and never had trouble with it but now no matter what I do I get this problem.

Gigabyte 990FXA-UD3 v1.1
2x kingston hyperx grey 2GB DDR3 1600
2x kingston hyperx black 4GB DDR3 1866
Gigabyte HD6850 1GB windforce
pre OCZ merger PC power & cooling silencer 420w
EVGA Superclock heatpipe tower HSF with F12 120mm FDB fan
evercool NCA-610EA chipset heatpipe tower cooler using arctic silver brand thermal epoxy on northbridge
OCZ agility 3 60GB SSD
multiple hard drives, varies as time went by
intel PCIE gigabit nic
viewsonic 1080p 27" monitor
old lian-li PC60 version 1 case, with extra 80mm exhaust fan modded in
2x nidec BETA SL 80mm exhaust fans
windows 8.1 pro x64

The BSoDs started when I got the new pair of 4GB kingston ram, but continued even when I ran only on my older 2x 2GB sticks which never used to BSoD so it isn't the ram.

I also did plenty of memtest86 and 86+ testing, never had an issue. I did multiple hard drive swapping, tried several new installs using different driver versions for everything, a different known good power supply, a different HD6850 video card, different network cards, even an old AMD propus 4 core 3GHz. new sata cables, all sorts of swapping and testing. Many reflashes of BIOS to older and newer, et cetra ad nauseum.

No matter what I do, if this motherboard is involved, I get this BSOD, usually when the computer is just idling. I have all power saving features off, stock clock, I tried overclocking underclocking overvolting undervolting stock everything a multitude of BIOS settings, many reinstalls of the OS...

The most nuts thing is I can run prime95 and furmark both in maximum mode and everything runs perfectly, but when idling, sure enough, BSoD.

Temps are never over 60c for anything, and I measure everything. The NB chipset cooler was put on to try to see if that could be the cause, but no difference at all.

Does anyone have any suggestions of what could be the cause? Is my mobo just fried?

Been a PC tech since 2000, for a few years it was my livelihood, now I am disabled and it's just my hobby.

run rescue/recovery/safemode ~ and use command line type in sfc /scannow
looks like your kernel got corrupted.

Apparently you didn't read my post...
I have done many reinstalls (nuke and pave, clean install) even onto different hard drives. It wasn't a one time event.

Weirdly I think I fixed that problem once with a change of CMOS battery and setting the exact time in BIOS and then setting time in os by sync over internet.
Funny enough, as a side note, If you sync to it is much faster than

I forgot to mention that I also replaced the CMOS battery with a brand new one, and tested the voltage of the old one which was 3.2v (well within spec)...

I sync time to and my BIOS always has the correct time, I'm pretty stringent about my computers always having correct time and date set, saves a whole lot of hassle.

Well, I'm running the same board, though Rev. 4.0, as my secondary rig (FX8350, 4 Corsair 8GB Vengeance DDR3-1600) and only ever saw that error once ...

First of... do the following:

  • Clean install Windows 8.1 and let it install the drivers from Windows Update. Then see if you see that kernel security check failure BSOD again (do NOT install ANY 3rd party driver!!!) when it sits there totally idle.

  • If the system is stable... get the latest Realtek drivers (OnBoard GbE NIC, Audio), get the latest AMD AHCI SATA (if you use that crappy "hardware RAID" you well better reconsider) and AMD chipset driver, latest VIA 801 Superspeed USB 3.0 driver (or does the Rev. 1.1 have the Etron USB 3.0 host controller?) from Softpedia as well as the Marvell SATA driver. DO NOT use ANY of the drivers Gigabyte is hosting on their download site - these drivers are so faulty it's not even funny (i.e. the driver for the NIC has severe problems with transfer speeds over SMB ("Windows File- and Print sharing")). If there's any difference between our boards in terms of peripheral chips used make sure you get the correct drivers.

  • Once you installed each driver and you don't see the kernel security check BSOD - now install the remaining drivers for your peripherals (keyboard, mouse, printer, USB thingies, ...) one-by-one - and check for the BSOD. The moment the system blue screens again you found the culprit ... in my case I had the very same BSOD happen with a Netgear WiFi driver (for a USB WiFi stick).

Also, for good measure: Since you are using unmatched DIMMs (two of them are DDR3-1600, the other two are DDR3-1866) I strongly hope you manually capped the max RAM clock to 1600MHz and didn't leave it at "Auto" (in case the BIOS trips over its own bits and ramps the memory speed to 1866 the poor 1600 ones will start going core meltdown rather sooner than later). EDIT: Also... what is the installation order? The should be installed in DIMM slots 1/3 and 2/4 /EDIT

In short - it's very likely a faulty driver causing the BSOD. In case you experience the BSOD on a cleanly installed Windows (with no 3rd party driver installed) I'd say you have a problem with your BIOS setup - in which case it might be insanely helpful if you could snap photos from the various setup pages with your smartphone / digital camera and post them for "look-see" and review.

Sorry, was supervising the pull of cat5e to wire the place I just moved into (not my place, they just needed it done and didnt know how but could do the physical work for me)

I have seen the BSoD on an entirely clean install without updates on the windows 8 start screen directly after intalling, before any reboot or update.

Yeah, I know the drivers there are bunk, I use the ref drivers for everything. Yes, it has two ETRON usb 3.0 controllers onboard. I do not use HSP RAID (host signal processing, where the cpu does all the work) I just use JBOD in this machine. For my storage server, I use FreeBSD and ZFS. As a matter of fact I am in the process of upgrading slowly to an iSCSI setup and just bought three used dual gigabit PCIE adapters with hardware iSCSI. Also, I will not get anything from softpedia, that is just asking for trouble sooner or later. Straight from the chipmaker site. I won't even use realtek nics, they are garbage, which as I said I use intel PCIE gigabit nic. Their file transfers with modern computers even without jumbo frames is near line speed of gigabit ethernet. I disable the rtl network in bios. And, as said above, the system has BSoDed with a fresh clean install of win 8.1 on the start screen on first boot.

Again I have seen it on clean installs on this machine with the varying hardware swaps listed without even a reboot. I also use an old WRT54G with dd-wrt in wifi bridge mode whenever I need to use wifi net on my machines, I do a whole lot of working on systems of all sorts of ages even including a 386 with DOS and windows 3.11, along with FreeBSD installs which its much harder to find a factory working wifi card for without net, chicken and the egg problem, so it's far easier to just have ethernet here even if my link to the net is wifi.

The ram speed in this particular motherboard uses the XMP timings from the slower ram, I have verified this many times, and also I have tried the system with just the old sticks AND just the new sticks in it, with a clean install for each, same problem. Also, the FX8xxx series only uses DDR3-1600 and lower officially and gigabyte set this board (and all other boards they make AFAIK) to never default/auto to beyond factory specs. Install order is very finicky with this setup, I have to have them in parallel order and unganged mode to be seen and work properly, otherwise I get OTHER problems. Again I stress that this problem happens now even with my original sticks only, and with the new sticks only... before I got the new sticks it never happened with the original sticks, which is what is so puzzling!

Sorry, not drivers, again as I said I have run it with a clean install first boot and get this a lot even with most of the hardware swapped out, as I said before in my post, if the motherboard is involved this happens. I have ruled out everything else. I have even moved so it can't be the power, besides having an APC LINE-R 1250 and APC surge supressor, along with an APC BackUPS NS 1050 (nearline iirc). I have done this with default BIOS settings along with gone through every possible setting with a fine toothed comb... this has been happening to me for over a year now and as you can see from my other replies to you I'm no spring chicken with this stuff, but I figured I should answer in kind since you took time out of your day to help me, which is appreciated so I figured I should show it instead of just say it! :)

If you want, I can take a picture of the BIOS settings at default which I have run at many times and got this.... but I doubt that will be helpful, again as I have run with almost every option available includig the most conservative with almost everything entirely disabled. If you still want, I will take a picture after a cmos reset and run it with those settings again till it bsods again, just to humor you... I am not being sarcastic here, I am being genuine since you are genuinely trying to help me, and I appreciate it.

Alright, since you are obviously no stranger to all the little details, and since you even ruled out the PSU as the point of failure... Well, if the BSOD even happens in a totally clean Windows installation - with "BIOS defaults" loaded - that's plain weird.

As two last resorts, just out of plain interest:

First. Is the system actually stable when you run, for example, Linux? If it doesn't kpanic (totally idle or maxed out) then you can safely assume that the hardware is okay (at least in my experience - since we both seem to work in the same kind of field - the Linux kernel is very prone to crashing on hardware that is not really fault-free).

In the same line of thought: Have you actually tried to see if other Windows version do work? While this may now be slightly against usual forum rules: There's a nice little tool called "WinToUSB" that can create a "Windows To Go" USB thumb drive / HDD (you need at least 16GB+ plus the Installation ISO). Maybe try creating a Windows 7, 8 or 10 one and give it a spin? Is way better than to re-install all over again; saves you quite some precious time (plus it can come in handy as a "full blown rescue system" as it isn't bound to a particular hardware configuration).

Second. Just because I once saw that weird "error"... did you actually ever inspect the DIMM slots for bent or corroded contacts? I once dealt with a server where one of the DIMM slots made bad contact with a DIMM ... memtest86/+ passed with flying colors, though Windows Server kept spewing "IRQL_NOT_LESS_OR_EQUAL" and other related "red herring" BSODs. It was just a conincidence that I noticed the DIMM socket problem because the DIMM had the "dot" (the contact usually slighty imprints into the gold pad) slightly off position.

1 Like

whoa. I'll inspect the sockets, never thought of that, just the kind of inspiration I was hoping for!

I was considering going back to win7, I may just do that for a while.

I also was considering playing around with the wintogo thing, rufus (my usb formatting / iso to memstick conversion tool of choice) has it as an option.

I guess I can install mint for a while, see what happens, though this is my gamer box so it's gonna feel like a pita to have to shut down and reboot to get back into windows to play some of my favorite games (such as heavily modded minecraft through FTB launcher, skyrim, asheron's call, et al some of which WILL NOT work in linux or are a PITA to get working)

I had run FreeBSD for a couple weeks compiling everything including custom kernel and such... from ports (xorg and mate, thouogh I usually use xfce) on this pc and it ran great.

Well, I created myself a Windows 10 "To Go" thumb drive (from a Windows 10 upgrade) so I have a copy "to mess around" (and I also have a Windows 8.1 one). Rufus (2.2.668) didn't work for me, was throwing some weird .NET(?) related error at the end of the media creation - WinToUSB, however, did the trick.

As for "rebooting into Windows for playing games" ... I hear ya. Same problem here (i.e. heavily heavy modded Skyrim et al) ... I know that WinE simply doesn't cut it.

Anyway, simply drop a note if you happen to find something of interest, I'm somewhat curious as to what the cause of that oddity is.

EDIT: If you're going to install Linux Mint. you may want to add "iommu=noaperture,pt" to the kernel commandline ... chances are you may face "syslog spamming" of "AMD Vi" errors once you install the ATI proprietary driver (same goes for the Nvidia one) - and the "noaperture" resolves the kernel complaining about the lack of memory hole for the framebuffer. /EDIT

1 Like