Return to Level1Techs.com

Need help setting up a rx 6800 on Pop OS 20.10

I installed my rx 6800 today and when i booted into Pop OS only one of my monitors would work and its running at a much lower resolution. Ive noticed in the about section of setting it shows that its using the “llvmpipe (LLVM 11.0.0, 256 bits)” driver instead of an AMD one, I tried installing the mesa drivers and they installed fine but my system isnt using them instead of the llvmpipe driver. Im not sure what to do to get it working so any help would be greatly appreciated

Kernel? Mesa version? You need to be on Kernel 5.9 at least and the requisite Mesa version that introduced support for the 6800, I think 20.2 or newer. See Michaels write up.
https://www.phoronix.com/scan.php?page=article&item=amd-rx6800-linux&num=2

1 Like

Should be the exact same directions as here.

1 Like

Kernel 5.9 didn’t work on my 6800XT, it gave black screen. Only Kernel 5.10 worked for me, but perhaps its different for normal 6800 cards vs XT

I don’t know. Maybe. I have not been able to get one of these un-obtaniums yet.