Need Help Installing Unigine Benchmarks in Linux (Valley & Heaven)

So I downloaded the Unigine benchmarks (Valley 1.0 & Heaven 4.0) for Linux.

Problem is I can't figure out how to install them. They are both .run files and after some searching, people seem to say "just run as executable". I've checked the box in the properties to allow "run as executable" but they don't run. I try open with>run software the computer thinks for a few seconds, then nothing happens.

System specs:

GA-H87N wifi
8GB ram
500GB 7200 HDD
GTX 760
Ubunto gnome 15.04

I don't know what I'm missing or doing wrong, but I just can't run them. Can anyone help me out here?

Much appreciated. Thanks. :)


Have you tried opening a terminal and then prefixing the .run file-name with ./

chmod +x ./
cd Unigen-valleyXXXX

That should do it

or install phoronix-test-suite and get nice graphs for a lot of different test profiles like:

Thanks, I did this exactly - it uncompressed and says it installed. It created a new folder where it installed. To try and run it I had go looking for the launcher and when I found it (in the "bin" folder) I right-click > run, but again, nothing happens. It still won't run. :/

Did you try what @WTFShelly suggested to CD to the dir and launch from terminal with ./valley?

Yep, I tried that. When I try running it in terminal by adding ./ prefix, it simply reinstalls it again.

When I try opening the executable in the folder where it installed, nothing happens.

sh /path/to/file

Also if you are running Gnome, Cinnamon, or Unity you need to set allowing of executing of file in the Nautilus settings. Then you can double click it and it will run.

I've never heard of the "Nautilus settings" before. Would you mind explaining what that is?

I have gone into the properties of the launcher file and made sure "run as executable" was selected.

Nautilus is your file browser in Gnome based GUIs. The option is under settings or preferences. I haven't used Gnome in a while so I don't quite remember.

Hello again.

Ok, when I try "sh path/to/file" (using the actual directory path) it says "can't open path/to/file..."

Also, I'm not able to find that option in nautilus settings anywhere. The only place I could find that is by right-clicking on the file itself and then checking the box that says "enable running as executable" which didn't change anything either.

I love Linux, but this is the part of it that frustrates me. Something that should be simple, like running a program, just doesn't work, even when you follow the instructions to install/run it to a tee. :/

do that.