Return to Level1Techs.com

Need help debugging dmesg output of Broadcom device

Hey there!

This is basically a follow-up to another thread I opened a while ago.

I have managed to get this card running after finding a recent post in the Ubuntu forum. 2.4GHz runs pretty good but there is no way to get a stable connection at 5GHz.

I read somewhere that the card needs to be set to match the region I am using it in which is Germany in my case. The P2P issue in my dmesg output, below is likely to be resolved by disabling WiFi direct.

May someone help me disabling P2P and set the correct region?

dmesg output:

[  +0,114453] brcmfmac 0000:02:00.0: Direct firmware load for brcm/brcmfmac4366c-pcie.txt failed with error -2
...
[  +0,399092] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Sep 12 2016 13:26:44 version 10.10.69.6908 (r658761) FWID 01-fed440e1
[  +0,009036] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code (0x30 0x30)
[  +0,040718] brcmfmac 0000:02:00.0 wlp2s0: renamed from wlan0
...
[  +4,695110] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  +0,018865] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  +0,510226] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  +0,494007] brcmfmac: brcmf_p2p_set_firmware: failed to update device address ret -23
[  +0,002739] brcmfmac: brcmf_p2p_create_p2pdev: set p2p_disc error
[  +0,002464] brcmfmac: brcmf_cfg80211_add_iface: add iface p2p-dev-wlp2s0 type 10 failed: err=-23
[  +0,014189] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  +0,268493] systemd-journald[687]: Failed to set ACL on /var/log/journal/27321d8138174adcaf35f46aff17c851/user-1000.journal, ignoring: Operation not supported
[  +1,009529] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  +0,580129] fuse init (API version 7.26)
[  +1,257844] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[  +1,035645] brcmfmac: brcmf_inetaddr_changed: fail to get arp ip table err:-23

This is still correct:

The kernel will grab the CRDA config from userspace and use it when it calls the initialisation of the interface.

1 Like

Thanks for the link. It didn't bring the result I was hoping for. dmesg was still logging the ISO3166 error even after setting it properly.
In the end I received good results using an old router and OpenWRT to use it as a client and just using the ethernet port of my PC. It wasn't as fast as the 2.4GHz of the broadcom card's connection but it didn't throw any errors at me.

I would like to keep trying though before I decide to sell the card again. Couldn't find a way to explicitly disable the P2P function. If somebody knows, please let me know.

idk if it's available for that specific card, but have you tried the b43xx-fwcutter drivers?

The firmware I am using is cut out via dd from a router firmware which uses the same chipset (there is a link to the instruction in my first post). It may or may not be the exact binary I need but there isn't much of a choice unfortunately.

There is probably a few adjustments to make regarding this card but good luck reaching out to the devs at their mailing-list... I already tried with no reply a couple of months ago.