Return to Level1Techs.com

Mysql workbench SSH error

I am having trouble using MySQL workbench to connect to my server via ssh. I had it working, then I changed and added an additional rsa pub key to authorized_keys file on the server. Now that I changed it I can’t connect. I have made sure I am using the proper ssh private key.

WARNING: Server public key has changed. It means either you’re under attack or the admin has changed the key. New public fingerprint is:
xx:xx:xx:xx etc.

I have deleted the known_hosts file in %appdata%/mysql/workbench/ssh. Still get it. I am able to connect to the server with the same key file in putty and filezilla. So I am at a loss as to what to do. Any advice would be much appreciated.

Recreate the known_hosts file as an empty text file in %appdata%/mysql/workbench/ssh. Now in Workbench, go to Edit => Preferences… => SSH (left-hand column). On the right-hand side, there is a field “Path to SSH known hosts file”. Click on the “Browse” or “…” button to locate the empty file you just created. Selecting the empty file and pressing OK will effectively clear your known SSH hosts.

3 Likes