My New PC Build has been crashing!

Hi guys,

So I built a new PC (though I still plan on adding to it, because I need to get a better GFX card, plus monitors and peripherals etc, and probably another SSD for game/video storage) but it likes to suddenly freeze and I need to reboot it.

The rig is as follows:

Case - Be Quiet! Silent Base 800 (Black)
PSU - Be Quiet! Straight Power 10 800W
SSD - Samsung 850 EVO 120GB (*2, one is boot drive with Win7 64-bit, the other is storage currently)
Motherboard - Asus Crosshair V Formula Z (990FX)
CPU - AMD FX-8350 (Stock Speed at the moment)
Cooler - Corsair Hydro Series H110 280mm (swapped fans out for Be Quiet! Silent Wings 2 140mm in Push Config, most likely change that in future)
Memory - G Skill RipJaws Z 2133mHz (2x8GB)

Also has an LG Blu Ray Burner drive, which was a mistake because it turns out I haven't got the codecs required to play Blu Ray discs (if anyone can advise on how to patch that I'd love your help lol). I've only got a cheap HD5450 in it as a GFX card for the moment, intending to get a Fury card (though I've been tempted by the Strix 980 Ti recently).

I have Windows 7 Home Premium 64-bit, completely up to date with Windows updates, and I'm running Kaspersky's Pure 3.0 Security.

Unfortunately my PC likes to freeze completely at random intervals, which is not ideal, because I plan on making this my main gaming rig, and streaming some games via an Elgato HD60, which will be utilising my other PC (won't bother putting the other PC Specs up, it might get confusing having two sets of Specs lol). There's never a BSOD, nor any white screens, it just freezes and any audio that's in the process of playing suddenly loops about half a second of the audio over and over until I hit the restart button.

The Event Viewer says the error is as follows:
Log Name - System
Source - Kernel Power
Event ID - 41
Task Category - (63)
Level - Critical
Keywords (2)

General searching on Google says its the Power Supply, am I correct in assuming I should swap it out for another PSU? I have a spare somewhere in my storage room, but I'd prefer an opinion or two from people here who know more about PC's before I make anything worse lol.



I've swapped out to my 620W Antec High Current Gamer PSU and installed my new graphics card, the error is still occurring, I need advice before I waste money on a new PSU that I might not need lol. Please help me? =)

If a another presumably 100% working power supply isn't working either, you might have a defective motherboard, maybe.

Otherwise ya, playing blu rays on PC can be difficult without paying(or "finding") software for it, you could get a blu ray player fairly cheap nowadays though, unless the plan was to copy the discs.

Do you have the latest BIOS? What GPU are you currently using?

Have you tried running the RAM at 1600mhz? Or setting the BIOS back to default settings?

I had a similar issue with my Asus M5A99FX PRO R2.0. I worked on it for a long time and even returned it for a new one. I found that it was simply very sensitive to static. Same manufacturer and chipset. Maybe your board has the same issue.

Sort of a bummer, I really liked it but the freezing is annoying. If you can still return it maybe you could pick up a Gigabyte GA-990FXA-UD3 instead.

Maybe there is a problem with RAM. Did you try running Memtest 86+ for passes/errors?

@Streetguru - I really hope it's not the motherboard lol, I want to stay with the ROG bourd (mainly because I like the look lol). As for Blu-Ray - there's a codec package or something I could buy? Do you have a link at all so I can find it? I've always used VLC Player, but I can't even figure out how to get BluRays to work with that now lol.

@Calculatron - I'll try to run the memory at 1600mHz for a while and see if it continues to crash. I was previously running with a Sapphire HD5450 (cheap and nasty card just so I could install WIndows etc) and recently got myself the Sapphire Fury Tri-X 4GB card. Unfortunately, there was an issue (which seems fairly common among people with ROG board and FX-8350/9590) which forced me to use the PCIE-8 slot as opposed to the PCIE-X16 slot - according to ROG forums, my new graphics card uses too much of the boards "bandwidth", and it was linked to USB3.0 ports? Somehow using USB3 and the PCIE-X16 slot forced the graphics card to not activate monitors and failed upon boot. Moving it to the *8 slot fixed that issue.

Unfortunately, it still crashes in game though, and I have done a lot more scouring of the web to find a solution. I even went into the BIOS and reset all to default (memory went to 1333mHz) and then put memory back to 2133mHz, then it froze upon entering the Voltage Monitor page. More scouring of the internet (it froze every time I rebooted and went into Voltage Monitor screen in BIOS) and it turned out one person had luck with moving their mouse from USB3.0 to USB2.0 - tried that and it stopped crashing in BIOS but still has the same power event error at different times whilst using the PC - it doesn't even have to be in-game.

According to DXDiag I am running with:
BIOS Date - 04/17/14 14:03:46 Ver: 04.06.05
I'm assuming that's the easiest way to check the BIOS without rebooting into BIOS itself lol, is there any further info you wouyld like?

@SSL4AJ - aww haha I hope I don't have to swap this motherboard out :-/ Though I have previously had the Gigabyte board you mentioned (without any issues like this too, though I have to admit I was only running a HD5670 in it lol)

@marekstanicki - I've just found the Memtest website, I've never used it before so I will have a look on YT for a quick "how to use" type guide and report back later with results lol.

<3 Thanks guys I really appreciate your thoughts on this!

Just exchange the motherboard?

I the search prompt in the windows menu, type "msinfo32". It should bring up a window with a system summary, which should tell you the BIOS version and date. The latest, for the Crosshair V Formula Z is version 2201 that was released on 5-7-15. (Oddly enough, the date you gave me isn't listed on the ASUS website.)

For funsies, as resetting your system, keep your RAM at 1333.

I am assuming you already read this.

I can think of only two other things. First off, if USB ports have caused you issues, make sure you are only plugging into your inputs that are on the back of the motherboard. I used to have bluescreens with a motherboard whenever I tried to connect via my case ports. Lastly, that ROG board has an additional 4-pin power connection, as well as the standard 8-pin CPU power connector. While (I believe) this is optional, it might help to be plugged into that one as well (if your PSU has the extra cable) - otherwise, make sure you are plugged in properly to the standard 8-pin.

You should have enough power... But, perhaps, if all other troubleshooting go awry, you may have to consider that your PSU is defective. (Surprising, from Be Quiet!)

Hi ! re-seat cpu, and remove ALL unnecessary toys, 1 memory module if possible, and run tests. Is the monitor you are using is tested and sound; an overload from monitor to graphic card will compromise video and screw-up different ways from there.
Check if electricity -120v - is stable.
Carry on and good luck !