My motherboard isn't working

Hi guys,


So I have an old h87 ITX Motherboard and it had a bent CPU socket pin, I bent it back very carefully and now I can't see where it it, so that means that it's bent back correctly coz it's blending with the other pins. But it still isn't working..


I tried with a Pentium g3258 and it wouldn't post or anything, apart from turn on the CPU fan.

When I tried my 4790k it was the same but this time the CPU fan wouldn't even spin!


Any ideas on what's up?


There is a green light in the motherboard that lights up when it's on and it is doing that, so it is getting proper power and some of the board is still definitely working.


My motherboard is a H87i-PLUS from Asus.



One other thing i'd like to point out is that this motherboard needs a BIOS update for use with these CPUs, but shouldn't it at least post and get into BIOS anyway? You don't even need components to get into BIOS right?

try clearing CMOS if you havent done that

It wont post with a chip is doesnt recognise. Update bios with compatible cpu then retest.

Oh ok sweet! How do I BIOS update? Because I don't have any old chips for putting into the mobo to get into it :/

Pentium G is indeed a haswell refresh chip, so big chance that you need a bios update. Which mobo do you have?

With an Asus you have usb flashback option. But with other brands im a affraid that you will be stuck.

H87i-PLUS by Asus.

I can't seem to find a BIOS flashback thing though, does this mean i'll have to go try and find and buy and old CPU just so that I can BIOS update?