My main M.2 no longer detected as bootdrive

So i installed another m.2(128gb) in my MSi Laptop with a working OS i was planning to clone it to a 2.5ssd. But when i booted it used the 128gb as the boot drive and then the loading screen had these preparing windows stuff and now my main m.2 256gb for this laptop is no longer detected as boot drive. But no files were deleted it just isnt a detected as bootdrive anymore its not even seen in the bios as one of the drive but on windows it can be read and all files are intact. I even tried to install the 256gb to another laptop but still not detected as bootdrive

I wonder if the problem is my laptop or the m.2 drive

I also wonder if its just a solution of bios update thing because the 2.5ssd is the same situation, detected in windows but not in bios

My laptop is msi gt73vr 7re
1060 6gb
16gb ram
256gb m.2

The other laptop is a sager np8652

The 2.5 drive is a sandisk 128gb

Vaguely sounds to me like the Windows Bootloader F*ed up again and put itself on the new drive…

This is my first encounter with this. You know any fix?

Maybe remove new drive /use windows repair utility on a start disk to fix boot loader on old drive (with no other drive connected).

Ill try that tomorrow its already late here. And ill update you tomorrow

Make sure you backup your files from that drive before trying, just in case.

Windows wants to put the bootloader on whichever drive is seen as 0 by the board in my experience. If you dont run windows on drive 0 then gg no re. I think this is the problem many linux users experience where windows updates its bootloader and overwrites grub.


I see. Do i need a certain version of win 10 to fix the bootloader or could i just use any?

I dont think it matters but I almost always grab latest from the internet anyway so idk. I’ve never had to restore a 10 bootloader. Should work fine in theory with any version.

1 Like

I have seen this specifically with the transcend 128gb m.2 nvme drive on a gigabyte b450 board.

I popped the drive in as part of a new build. it showed up. I stuck my usb win 10 in and rebooted. Did the normal install process and at 34% the system froze and the m.2 drive disappeared.
Put drive into another machine and it didn’t show up.
I RMA’d the drive and got the exact same drive. The exact same thing happened on the second drive. freeze at 34% install and dead drive after.
So I installed windows on the same system using a 2.5" ssd and no issues. So the usb drive was good and the system was good. just a bad drive.
When I RMA’d the second drive I took the system to the store with me.
Explained what the issue was. Used an m.2 drive they had to figure out if it was a drive issue or a slot/mb issue and the stand in drive took windows from my usb no problem.
got a different drive for the 3rd attempt and had no issues afterward.

The m.2 drive I have used on other builds with no problems.
I put it down to incompatability somewhere between the controller on the drive and the firmware on the motherboard.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.