Return to Level1Techs.com

[MSI Z97-G45] Forgotten BIOS password


#22

Had another look based upon the the visual appearance of the chip here: LINK

Found a similar looking (8 legged, relatively square with a tiny little circle) it's a...

http://www.datasheetq.com/25Q64FVSIQ-doc-Winbond

I'm terrible at this.

@MisteryAngel halp


#24

The datasheet for the 'Winbond W25Q64FV (PDF).

It's just your garden-variety 8-pin SPI Flash-ROM chip - nothing out of the ordinary. This chip just contains the BIOS, there has to be another chip somewhere on the board (the PDF manual for the motherboard isn't of any help either as it even doesn't tell one where that SPI Flash ROM is located) that holds the CMOS setup data.

I'd start looking around the battery for some chip which is either some SRAM or is a realtime-clock chip. Google for the brand, model number and pinout (i.e. Winbond W25Q64FV pin-out) and look at the data sheet. That should give you a idea about how long the chip retains the stored data upon disconnecting the buffer battery (pulling the coin-cell that is).

However, there's also a good chance that they may store the password inside the "PRAM" area of the UEFI.

As an example: Some ASRock motherboard I once dealt with would actually reset the CMOS setup upon setting the "Clear CMOS" jumper but retain the user-configured Overclocking profiles because they were stored in the non-volatile UEFI configuration area.

I also recommend sending an e-mail to MSI's support. Can't be they don't have a "backdoor" password or some undocumented way to clear a set CMOS password at ease.


#25

I've contacted MSI's support and they just told me I'd have to contact the reseller, pretty poop. The seller doesn't even offer this motherboard any more and I bought it in late 2014 so there's not much chance of any help there, plus I don't want to have to send it away for heck knows how long.

How many pins would this SRAM or realtime-clock chip likely have?


#26

Sorry to hear, but hat goes incredibly well with my experience with MSI's tech support in the past ... either some reply from some, please excuse me, total retard or written by some monkey barely able to understand English, let alone express himself in a meaningful way in English.

Given the post you dug up ... simply pull the battery, set the Jumper, disconnect the PSU from the motherboard (just for good measure) and let it sit there for 24 hours. Then see if it worked.

Another idea ... if at all possible (doesn't ask you for a password) you could try to re-flash the BIOS. That usually clears the configuration area the UEFI uses for storing its logs and stuff ... could wash out the password as well.

EDIT: As for the chip ... depends ...

A SRAM chip could be the same thing as the BIOS chip ... a tiny thingy with 8 up to 16 pins. A realtime clock chip containing some "non-volatile" SRAM... well... since motherboard manufacturers are known cheapskates and cut-throats ... I'd say they buy the cheapest crap they can possibly get in some back-room in the Shenzen market ... 24-pin SMD package, most likely.

If you can't ID the chip, simply throw the brand + model numbers into a post and we'll have a Google around.


#27

Well, things near the battery... no idea what this one is.

NIKOS
P45N02LDG
GNB900823

http://www.datasheet-pdf.com/datasheet-html/P/4/5/P45N02LDG-Niko-Sem.pdf.html

lovely high res image of the entire board: LINK

Maybe circle the promising shizzle?


#28

I would also suggest to give msi a call.
Maybe Msi has some specific tools availeble to clear Cmos passwords.

For the rest we will indeed need to look for any other solutions.
But the best solution is still to call msi first, and ask how to reset bios password.


#29

That image is a lot better than what I found while searching for a picture of the board, still not "HiRes" enough to read the markings on the chip.

Anyway, going by the looks - maybe the 8-pin chip between the coin-cell battery and the heatsink of the chipset? Going by the package and the pin-count, that could be another Flash-RAM type chip (but could also be a Op-Amp or something along that lines... looks can be deceiving). I don't think a SRAM or RTC would be terribly far away from the actual battery.

Anyhow, Googling around for a bit:

  • Information on the topic of "UEFI BIOS board" and "how to get rid of a setup/supervisor password" is non-existent. I find that somewhat surprising. On the other hand... I never had to deal with a UEFI BIOS system having a password which got forgotten set yet... I only had to deal with the usual dead-flash (BIOS flash went wrong) problems where re-flashing / replacing the chip was the task at hand.

  • It is somewhat safe to assume that a "master password" can be ruled out. I only found one post relating to some ASUS board where you can bypass a set password by setting the system to a certain date from within Windows, rebooting into the UEFI setup and inputting a very non-sensical letters/numbers combination into the password prompt. Seems like some engineer had some fun.

  • There's also somewhat overwhelming "evidence" that the password is actually saved/stored in the UEFI configuration space (most likely in the SPI Flash also containing the BIOS). Another post I found on the topic also talked about some motherboard where it was stored in the UEFI AND in the battery backed-up "NV"RAM of the RTC (Real-Time Clock) - replacing the SPI Flash with a pre-flashed chip didn't lead to the intended result, but worked after the CMOS was cleared through the usual "jumper" means. That would be a pain in the rear as there's not a single socketed chip on your board. Even if you would be able to obtain a empty SPI Flash and program it with a BIOS (i.e. via an Arduino or Raspi or Programmer) you would need SMD soldering skills to replace the chip for a trial-and-error run. /me is suddenly glad his boards all have socketed DIP SPI Flashes

Fascinating topic, I'm really surprised that there's not much info out there.

If the 24h+ "running it dry" doesn't work and MSI lives up to their reputation biggest-time ... the last resort would be to try and replace the SPI flash past a new, pre-programmed, chip - and hope they have no "shadow copy" stored somewhere else.


#30

IMAGE

although MisteryAngel already said...


#31

The UP0104S turns out to be a relatively commonly used ACPI controller from UPI-Semi - not a power (driver/regulator) chip as @MisteryAngel guesstimated but also not something that would store any data.

Well, you could go through the other 8+ pin chips scattered around on the board but I think the thing we're after is most likely tucked away in the SPI flash. If you have a friend/colleague/acquaintance being well-versed in electronics or there's a well-equipped repair-shop around in your town/city - you could always try to hook up to the SPI flash with a few test-leads (should work without soldering the chip off the board) to try and dump the contents chip to see if you can find, and subsquently erase, the stored password. I linked the datasheet of the chip-series above, so any half-way decent electronics engineer/hobbyist should be able to work it out.

...unless MisteryAngel's tip about trying to call MSI's helldesk results in some solution.


#32

In case you have to read or reflash it, the SPI flash seems to be supported by the "flashrom" utility:
https://www.flashrom.org/Supported_hardware

If you have a Raspberry Pi you could run flashrom on it and hook up the chip to the SPI GPIO pins on the RPi.


#33

@SpaceCat Have you tried applying a bios update to see if that will clear it.


#34

Yep.


#35

i remember there being tools that let you brute force the bios password. give me a day or two and ill see if i can find one for msi.


#36

The information i could find on the chip tels me its a power regulator from upi sem con.


#37

Something I've seen mention of in a couple places is that overloading the keyboard buffer can produce interesting results (by pressing esc key over like, 100 times, per se).
I might just take this as an excuse to go bash my keyboard out of frustration for a bit.


#38

can you get me a picture of the bios screen?

EDIT: also look into Hirens boot cd. there is a bios password cracker in there.

http://www.hirensbootcd.org/download/


#39

whacha mean by the "bios screen"?
The prompt for a password?


#40

the password screen.


#41

in the bottom right is the code "A8", becomes "D8" if I get the wrong password 3 times in a row.
Definitions for these codes are found here: LINK
Just "Setup Verifying Password", then "Invalid password".


#42

if you can boot into cd or usb then try hirens boot cd.