Return to Level1Techs.com

[MSI Z97-G45] Forgotten BIOS password


#1

I've tried:
* Clear CMOS button
* Clear CMOS jumper
* Removing the battery (for around 11 hours)

After any of these, when I reboot I'm given the following options:
F1 : Enter Setup
F2 : Continue
... and it still asks me for the password when I enter setup.

Now I'm stumped.
The only option from here that I can see would be to replace the BIOS chip entirely.


[MSI Z97-G45] Forgotten BIOS password continued
#2

Have you tried dogsrgr8 and 69catpics yet?

No but srsly good luck


#3

I would be stoked if they'd rely implemented "security" and have the pwd in non volatily storage.
How long have you removed all power sources (PSU + cmos bat)? It can be that still some caps on the board hold up the power enough if you do not wait long enough.


#4

11 hours.


#5

ooohhkk.. thats plenty hours O.o

I mean MSI own guid is like this

It is important to understand that clearing the CMOS will:
-Restore BIOS's default settings.

It is important to understand that clearing the CMOS will not:
-Restore the original BIOS code (will not revert back to the original bios version).

  • Old CMOS clearing method *

Step 1:
Disconnect the main AC power by either shutting off the power button on the back of your power supply or simply pulling out the power cable.

Step2:
Wait a minute to be sure all the capacitors and coils have discharged.
To be really safe you can press the power button which will drain the capacitors for sure.

Step3:
Move the CMOS jumper to the clear position, this is usually done on MSI boards by moving JBAT1 from it's original 1-2 position to 2-3 position as demonstrated in the photo below.
If you are not sure or have a non MSI board you must find the correct jumper in your motherboard manual.

*Note to all nForce2 users, your board usually has a special "safe mode" jumper for the FSB. You should also set it to the safe setting in case you have been overclocking since the normal clear CMOS jumper will not reset the frequency settings on these boards. You may refer to your user manual.

Step4:
Wait a minute to be sure the CMOS has been cleared.

Step 5:
Return the CMOS jumper to it's original position.

Step6:
Restore power to the system.


which I assume is what you did so far... that does not sound great


#7

This guy:

https://forum-en.msi.com/index.php?topic=259520.0

Seems to have managed to get in by taking out the battery for almost 24 hours, on a Z87-G45.

I might have to leave this until my next holiday. This isn't a particularly huge issue at the moment, I can leave it be for a bit.


#8

Incredible wired; I would give shorting the +/- on the bat a go, as that should discarge all caps that are somewhere on that rail. If that also not works... wait and try the 24h version...


#9

Nope, same situation.
(I'm given the following options:
F1 : Enter Setup
F2 : Continue
... and it still asks me for the password when I enter setup.)

Still open to other ideas besides the 24 hr option.


#10

Sadly I could also not find any specific workaround for your MB; as the generic ones fail I have to resort to declare my defeat. sry.


#11

Get a new BIOS chip which should be pretty easy to replace. Should only cost a few bucks and make sure that its the right chip for your motherboard.


#12

I'm aware this is a solution if you could be bothered to read the 64 word essay of an OP.
If you'd maybe look at the actual board you'd know it's soldered on, so not easy to replace.


#13

Normaly if you unplug the system from the wall, and then take out the bios battery for a few minutes.
Then it basicly should reset the bios to factory default.
Unless the bios password is hard stored on an additional chip.


#14

Is there any way I could identify this "additional chip" and format/replace that?
Would replacing the BIOS chip do nothing if there is this "additional chip"?


#15

You could look up the datasheet for the bios chip and see if their is any non volatile memory on it other than the flash for the actual firmware such as an EEPROM etc.


#16

I´m currently looking for any information if there is an additional chip on it or not.
But it doesnt sound very likely.
I would atleast recommend to contact Msi for now.

In the mean while we might look arround if we can find some method to fix this.
It would ofc be rediculous if you loose your bios password, that you are unable to reset it back to factory defaults.
Allthought "if im right", there is an option in the bios, that exaly says "password clear" and if that option is set to disabled.
The bios password will indeed not be cleared after Cmos reset.
I think that were your problem sits.

Does the G45 Gaming has dual bios?
Edit: nope its single bios.


#17

Also i hate bios passwords, i never set them ☺
Currently digging trough msi forums.


#18

For a desktop usually not as important; but on my laptop its a vital part of its security structure.


#19

I managed to get a picture of the label on the chip

On a d5100, without an SD card (because I don't have one atm), so I took a pic of it on my d5100 wiht my nexus 7.
yep


#20

Thats a power chip that basicly powers something.
Its not something that has a password stored what so ever. ☺


#21

Well I've no idea where it's located on the board then.