Msi z77a-g43 not posting after oc

hi! this is my first post here!

i did some overclocking with my i5 3570k, msi z77a g43 mobo, 8gb kingston hyperx blue memory 1600mhz, win 7 ultimate 64bit

i got to 4.2ghz easy, it was all stable and good, so i pushed it to 4.4 ghz. When i rebootted, it didnt post even to bios, just got a black screen with small "a1" in the bottom right corner, i tried with gtx 560 and onboard video. no effect. Then i took off the bios battery for 20 secs and putit back, this fixed the problem for a while.

I tried to push it to 4.3GHz this time and same thing. This time battery trick didnt work. this time i got screen that told me my specs and "all setting are reset to deafult" and gave me options to either continue or enter setup. if i press continue, it re boots and goes to a1 screen again. If i schoose enter setup it shows text "entering setup" and gets stuck there. i let it run for 30 mins, nothing.

so my gues is that the bios or windows is corrupt. how can i flash the bios or something? or is that the problem?


E: Problem solved. I removed my hdd, extra ram and gpu. Then i connected jumpers and then it just decided to work.

Also i did some research on the mobo, seems like it's not even ment for overclocking as you cant change your voltage control to manual. Which was never ever mentioned in the marketing of the mobo, i bought the mobo because its seemed cheap and still overclockable. It has good features, but normal overclocking is aparently a big no no. BS! >: (

Never go cheap when overclocking is in mind. The only cheap boards that actually overclock well are from AsRock and Biostar. MSI you want g55 and up. Is it too late to RMA the board?