Return to Level1Techs.com

MSI Driver help


#1

Hi all, I’m reposting this here; I’ve had it up for a few days in the msi forum and the most help I’ve received was a strike for not initially posting it with proper layout.

I recently installed the msi x470 gaming m7 ac and i have struggled to get many of the drivers to run since then. None of my downloads open immediately, they all take me to the download folder. Most downloads allow me to run them from the setup file, but the msi drivers either do not, or once they’re downloaded give me an error message that my platform is not supported. I will post a follow up to this with each drivers behavior after i take apart the system to see what ram and hdd i have.

I have tried extracting the zip files to several different locations to no avail.

I have tried reloading the bios.

I tried a clean wipe of the hdd and redownload of windows 10 64-bit

I tried running the cell phone apps like mystic light but nothing shows up in the box for devices on my network

If i’ve tried anything else I can’t think of it right now.

Main Board: MSI X470 Gaming M7 AC
Bios Version: 7B77v13
Video Card: EVGA GTX 1070ti
PSU brand and model: EVGA SuperNova 750 G3 80 Plus Gold
12v rail Rating of listed PSU: 62.4a
CPU: Ryzen 7 2700x
Memory: XPG Adata 8gb 2400
SSD/ HDD: Evo 960 1tb M.2 SSD, WD Blue 1 Tb 7200 rpm HDD
CPU COOLER: Wraith Prism
Raid Card: N/A
Sound Card: Asus Xonar DGX PCIE 2.5
Keyboard: Cyberpower PC
Mouse: Cyberpower PC
Any Additional hardware plugged into your system: 4 case fans.
OC: (Yes / No) Not yet.
Operating System: Windows 10 64-bit


#2

You are downloading the win10 64 driver versions for your motherboard? And the fresh windows 10 download is version 1803?

It looks like it has lan, sound, raid, chipset, and Bluetooth drivers available for download. Raid you can ignore unless you are using the raid on the motherboard.

More info on the exact error and driver would be useful.


#3

thank you for your fast response. i’m pretty sure you helped me in my first post on this forum as well but i’ll have to go back and check later.

yes to the first two questions.

the only driver on that page (assuming you’re looking at the mobo’s support page) that worked for me is the amd driver. I actually have to take my grandmother to a doctors appointment right now, but this evening I will go through and write a runup of how each driver is behaving from download to attempted setup.

edit: i also tried different versions of windows 10 downloads just to make sure it wasn’t me, but every other downloaded driver for my gpu, sound card, and all the parts of my simracing rig worked on the windows 10 64bit


#4

Okay, these are the experiences by driver from download:

killer control center: download file, once done i’m given the option to open it if i click on it, i open it, and it takes me to the folder it downloaded to. on this one, none of the files are labeled setup, and clicking on the ones with a file type labeled “set-up information” opens a page with what i’m assuming is coding. if i back out to the “downloads folder” killer control is a zipped file, if i extract it, it creates a second unzipped file that has the command center app button. click it and it downloads killer command center but when i try to open it it brings up a loading screen that never changes no matter how much time i give it. (i have given it days in the past just to make sure)

intel wifi driver allowed me to start set up by extracting the zipped folder and by selecting autorun i believe I’ve been able to download it, if it’s only a background driver that doesn’t have any sort of program associated with it.

killer lan driver doesn’t have a clearly marked setup application. i’ve clicked on a few that say application and a few that say setup but i haven’t been able to get anything to work.

realtek hd universal driver allows me to open setup from the file aptly named setup in the downloaded driver folder. I have had this one running.

amd raid i’ve been able to get to the download screen but i haven’t actually downloaded it.

amd chipset i launched from the file

intel bluetooth allowed me to launch from the autorun application.

honestly,typing up this i found one of the things i was doing wrong. however i still haven’t been able to get the killer command center to work for me, and some of the things my board supposedly came with like mystic light arent included in that list of drivers. i had to find a mystic light download file posted on the msi website and after going through all the same steps it eventually gives me a pop up that my platform is not supported.

i don’t understnad why just switching the board made downloading programs and drivers completely different. they used to just launch without having to rifle through the folders looking for the right application

also i apologize if i’m using the wrong terminology, i’m obviously a newby


#5

It would be a good idea for you to enable show file extensions in windows explorer.

The installers will be executable files, with .exe extension.

Seeing extensions also prevents you from accidentally opening malware labeled something like picture.jpg.exe where by default you see picture.jpg and think it is a picture not a executable.

The extra programs are located in the utilities tab of support page for your mobo- https://www.msi.com/Motherboard/support/X470-GAMING-M7-AC#down-utility

AMD raid is not needed unless you are actually using the raid features of the motherboard.

You can open up device manager to see if there are any devices missing a driver.


#6

omg, you just changed my computering experience tenfold.

Thank you.

I’m quite happy I joined this forum. hopefully i’ll be able to positively contribute soon.