Return to Level1Techs.com

MSI Creator TRX40 - won't shut down without power button, won't wake from sleep either

Hey guys! I’m in the process of setting up a new daily driver system (specs below) I intend for all-around productivity (and non-productivity) - read distractionary pursuits.

So far - just loaded clean install of WIN10 Pro 64, and did all OS updates, then loaded all drivers and updates. Now I’m at the “window dressing” stage of RGB scenes and stuff.

Having challenges with system not shutting down from Windows, and not waking from sleep. I’ve selected proper power profile settings in device mgr., and in BIOS (haven’t tried eRP changes though because it seems counter intuitive, but what do I know?).

Also, Corsair RGB utility settings do not persist after shut down and reboot.

Question; is MSI Center as big a piece of… let me ask another way, “can I do without it?”

Any suggestions for this particular incubation phase of a new build comments, questions, or concerns is greatly appreciated.

Thanks!

New build:
WIN10 PRO 64
MSI Creator TRX40
Threadripper 3960X
Sabrent Rocket NVMe 2TB
MSI RTX3970 SUPRIM
32GB Vengeance
Cooler Master Wraith Ripper
Thermaltake 1500W
MSI Sekira - Open Air (front & top panel off [plan to modify front and top fans placement] because this thing is a hotbox better suited for gardening than a high-end computer case)

So, as it turns out; in truly wanna-be nerd fashion, my desperation to escalate to LV1 forum support has proven unfounded. I turned off “Fast Startup” in Windows 10 power settings and that did the trick! I instantly felt like a genius and mentally challenged at the same time!

However, there is still hope I will get some valued LV1 input about the Corsair iCUE RGB utility not saving profile after shutdown, and also about MSI Center (that replaced MSI Creator Center [that replaced MSI Dragon Center]) and what a wonderful feat of engineering it is!

Thanks guys!

1 Like

I’m reading this realizing I am having the same issue with the MSI X399 MEG Creation motherboard.

and the wake from idle has only been an issue since I updated to Windows 11. I’m going to see if there’s a disable Fast Boot option.

Captain_N, any luck with disabling Windows 11 fast boot option?

1 Like