MSI 970a-g46 usb 3.0+ wd 3TB my book external hdd

Ever since I added one 60 GB ssd and am now using it as my boot drive, my onboard usb 3.0 ports on the back of my motherboard REFUSE to show my 3TB western digital my book external hard drive in bios and windows explorer.

this ssd filled the 6 and FINAL sata gen 3 port on my motherboard

My first thought was " ok is this a bandwidth or controller issue? "

Next thought " nope.  the sata gen 3 ports are ran from the cpu, i think.  " microsoft standard ahci sata controller" or something like that in device manager.

when I plug this My book into my front usb 2.0 shows up and works just fine..( just of course at CRAPtacular 30 MB/sec maxed speeds.  when you're transferring a massive blu ray movie copy, it takes 20+ minutes often)

When I plug in any other usb 2.0 thumb drives into the usb 3.0 on the back of the motherboard ( both ports tested) they show up and work just fine.

Also when I plug in the My book to my wife's laptop usb 3.0 port ( intel cpu ftr)  it shows up and works at the 85 to 105 MB/sec speeds when transferring big files.

Thus I'm confused as to what the problem is.  I've tried both ports with the My book.  Tried more updated drivers from Msi's website  clicking drivers of course to find it.

I'm banging my head.  I tried disconnecting on of my optical drives JUST to see if that mattered.  It doesn't.  Still same problem.   Tried disconnecting my 3TB Seagate Barracuda internal hdd, (movie and pc backup storage), still same problem..thus eliminates my first guess about it being a bandwidth issue.


Help please? Thank you.


So no one has encountered this problem besides me?  ...... :(

Any takers on this problem?   going once..  going twice?

Anyone have any ideas that I haven't tried yet?  Any help in here?  WD support is about as useful as a tick on a healthy dog.  Their level 2 tech support is just as stupid as their pons in which they only know how to read from a manual instead of READING what the customer has already told them that he tried in troubleshooting the problem.  I'm about ready to throw this POS in the trash.  I'm never buying another WD storage solution again.  

well i would first try to update the bios to the newest version, after that download en install the latest chipset drivers.  also did you download the AS media usb3.0 driver?

If you received this message as a duplicate, I apologize.  I'm still new to dealing with forums some.


I already have the newest bios and chipset drivers.  again I tried multiple types of usb 3.0 drivers: as media and xhci whatever that is :  .  None of those variables matter.  My last idea is to install my pci express x1 usb 3.0 2 port expansion card that I have used in this troubleshooting situation into my mother's desktop machine and see if the damn MyBook shows up from either of it's 2 usb 3.0 ports.  If yes..then I KNOW it's something to do with my motherboard, if not then I know something is goofed with this MyBook.  

Beyond that, I am out of ideas.

yeah you could deffanetly try that.


Ok I hooked this MyBook up to my wife's laptop to the usb 3 ports.  All instances showed between 35 and 40 max megabytes per second transfer rate which is usb 2.0 standards.  I have finally figured out the problem.  It's either ONLY the usb 3 cable, or the usb adaptor PCB chip thingy that is built inside the housing of the external hard drive enclosure that is connected directly to the WD Green hdd.  

 So do I buy a new usb 3.0 to risk wasting between 7 and 17 bucks to HOP that is the only issue to resolve it? Or do I just open this pos up and just add the WD green drive inside it to my desktop and to storage spaces?


Thanks for responding to my cry for help lol.  :D