Motherboard dead after moving case?

Greetings, everyone.

I built a PC for gaming in a 4U case a couple years back, and yesterday I added slide rails and mounted it into a rack. When I went to turn it on, nothing happened.

After a few hours troubleshooting, I found that the PSU appears to work (I plugged it into another system, which worked, and shorting the pins starts the PSU fan), but having either the 8 or 4 pin (or both) CPU power plugged in to the motherboard in question will stop the system from responding, at all. The only thing that happens is that the motherboard LEDs pulsate. The chassis power button does nothing, no beeps, no debug codes displayed. Unplugging the CPU power will power all the fans, etc, but there is no display output. I tried 2 video cards, as well as the HDMI port on the mobo (it’s not an APU but I figured what the hell). I moved the RAM around, removed it entirely; same result.

Here’s the weird thing- before I started unplugging power cables, etc., only the exhaust fans on the back would spin. The cpu fan/water pump would not turn on. The video card was receiving power, but the fans would eventually spin down. Only after I opened the case and started troubleshooting, did the symptoms change and eventually result in only LED illumination.

I’m thinking the motherboard is dead. Thoughts?


Asrock X470 Taichi
Ryzen 2600X
GTX 1080ti/980ti
8GB (i think g-skill) ddr4
Various m.2 and sata drives

Thanks for any insight. Microcenter is kind of a haul from here to be buying and returning parts that weren’t the problem, so any help is appreciated.

1 Like

Take the motherboard, gpu, ram, cpu and FAN (no w/c), setup on a cardboard box (no case) with a known good PSU, what happens?

Sounds like something’s loose or shorted.

1 Like

Double check the holes on your motherboard and count the standoffs. Sometimes there can be some pre-installed that you may not need.

1 Like

I agree with gordonthree - sounds like something shorted?

I took it out, unplugged everything, used a different psu, changed the cmos batt and reset again, but same thing. Trying it with no memory installed is the same. I suppose I’ll go get a cheap cpu and another MB; I’m not thrilled about un/reinstalling all the mobo drivers, but if it works, it works.

I also blew it down with canned air. I have a suspicion it could be a bit of foil tape that got lodged in it long enough to damage it (I have some foil tape on the vent holes, and moving it or adding the rails may have flaked a piece off), though I think it was really probably something simpler, like a solder joint somewhere broke loose when I moved it or something. Idk.

Time for an upgrade?

1 Like

Update… tried same board, new CPU. Same issue. Swapping the board, now.

Yep. Going from x470 taichi to x570 taichi, which leaves me more upgrade room in the future, anyway. I would have bought another identical x470 if there was one in stock and at a decent price. Amazon has em but having the computer in pieces for another week irks me more than the cost and time is worth.

It was amusing, though, to see the store employee’s face when I bought the cheapest athlon apu with a $300 mobo. “You’re… not going to put that cpu in that board… are you?” Silver lining.

Pics, for funsies

1 Like

Congrats khaudo, I am using the same motherboard in my build, it is being used in the desktop I am using to type out this post. The only complaint I have with this motherboard is the manual it isn’t written very well, and there isn’t any marking on the motherboard. I found I was guessing a lot where the power switch wires went, and which were the correct placement for the audio.

Maybe attempt to RMA and have a spare board for the future?

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.