Return to Level1Techs.com

Motherboard BIOS issue

helpdesk

#1

The board is Asrock AB350 Pro4.
The system have been working fine for about an year now.
The issue is:
When I boot from complete off, the PC just freezes other the hardware check. It reaches the Asrock logo screen and dies there. I have to reboot it 2-3 times to be able to enter BIOS. When I enter BIOS - it’s a mess. The SSD is taken out of boot order, so the system tries to boot from the hard drive, and it’s no windows on it…
I reverted the UEFI to it’s default settings, which seemed to have solved the issue for a couple days. Yesterday - the same thing… 3 reboots until it finally passed the hardware check and loaded Windows normally.

The only idea I have is to flash BIOS to somewhat newer version.

What baffles me is that the system was working fine for about an year now and it was rock solid. I had no significant issues and out of nowhere - this…

Any ideas?


#2

update bios… imo remove cmos battery and see if that just resets it all w/o software. could be psu messing with the board too. so checking those connections if those are not the issue i am out of ideas my dude hope. i was of some help


#3

Things that I would do (testing after every step):

  • Remove cmos battery.
  • Re-seat RAM / reduce number of modules to one for testing (in the right slot)
  • re-flash BIOS
  • visually inspect the board for burned, blown, discolored or missing components. Specifically take a look at the capacitors beside the VRMs (if they are lifted off the board slightly or other defects)
  • Test with another powersupply if you have one. Was the powersupply used before in another build?

#4

OK, I mean why would I need to do that? The system was running just fine for an year or so…

It’s the PSU I had in my last system… 430W seasonic S12II bronze… I know it’s 5-6 years old, but still…
You think it’s time for a new PSU?

PS: also… If I boot with one stick of ram I will have to fit all sticks of ram back on and I will run at the same issue if it is the ram, correct or am I missing something?


#5

RAM can be finicky at times. I always suggest to check that because it is easy and you might be able to rule out RAM related issues. From your description I don’t think it is likely this is the problem but troubleshooting is all about removing variables.

It’s not that old that I would immediately jump at the PSU. However what you are describing can be caused by bad power delivery (i.e. filtering because a cap blew out).

Another thing to check is the graphics card, not likely but this is how it goes with troubleshooting. I usually recommend to try the easy stuff first even when it’s not likely the fault, you never know.

If it is a seating issue it usually gets resolved by reseating the RAM. If it is a wonky module you can check by switching out the modules (RAM does not go bad all at once). I don’t think it is likely that it’s the RAM however, just a low hanging fruit.


#6

You mean taking out and plugging back in the GPU?
I can just take the entire thing apart and put it back together if that will solve the issue…


#7

no reason to take it apart right now. As I said, check the easy stuff first.

Regarding GPU troubleshooting (also not likely the issue but easy to check):

  • change the cable if possible
  • change ports of the monitor cable on the GPU and monitor (if possible)
  • re-seat power cable of the GPU
  • re-seat the GPU
  • test with another GPU if possible

Also, maybe discribe the exact behaviour in a bit more detail.

  • How reproducible is it?
  • It’s a sata ssd right? have you tried changing cable and/or port?

#8

unlikely to solve this… diagnoses the issue so you know how to fix it teardown and rebuild might fix it but if it happens again you want to know what the issue is…


#9

Could be the CMOS battery beeing dead


#10

Good thought, unlikely but also easy to check.


#11

Also, what happens if you boot without any storage media attached?
Try unplugging all drives and reboot twice. Can you reach BIOS without issue then?

(this might be the more likely route, since you mentioned the boot issue with the SSD before)


#12

Hm… After only an year…


#13

I come home. I press the start button, the system reaches the Asrock screen, it freezes there and just stays there. DEL doesn’t open UEFI, nothing works, but the restart button.
It freezes 2-3 times at the Asrock screen and then it boots like nothing ever happens.


#14

:thinking:

hmm … sounds eerily similar to the behaviour on a board of my colleague where he accidentally ripped a cap of his board. Probably a coincidence. Check without drives next.


#15

Mkay, I have quite a few things to try out…
I’ll give you some updates in about 5-6 hours cause I’m at work now…


#16

sure :slightly_smiling_face:


#17

Could be, but then you should mainly encounter the issue wenn you unplug your system from wall power.
Which i assume is not the case.

I would still advice to update the bios firstly.
Others mentioned to clear the cmos to factory defaults allready.


#18

So the first step you advise is to update the bios before I do anything else?


#19

Yeah i would try that firstly.
Just read what the latest Stable bios has improvements for on their website.
Most of the time you can get some info out of that.
Still weird that the system has worked fine for more then a year.
But yeah strange things happen.

If the board freezes on Splash screen, then its probablly something related to your HDD or SSD’s drives configuration.
Or some of the connected usb devices might cause an initalization error.
Because if you do get a splash screen, then it means that the vital parts like cpu, memory and gpu are detected.
Otherwise you will be left with a black screen.


#20

You can sure try, it won’ hurt anything. In case the last BIOS is an AGESA one I would recommend to skip that one and use one version earlier.