More problems with gentoo install

So I went to configure the network interfaces. I ran the command "ls -s net.lo net.enp0s3". I was told that net.enp0s3 isn't a file or directory. How do I configure this interace if the file doesn't exist?

Hey Tex,

https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Networking

Your NIC I assume that it is ethernet, what does ifconfig say ?

Some recommendations,
- 1st if you are using a gentoo image either minimal or livecd then it have package "net-setup" this may assist you in configing your network.

  • 2nd I would try and use the new livecd, or if you have issues use ubuntu and Chroot from there. Becuase GUI make it easy to have the handbook open while you are installing

  • 3rd and finaly use IRC, gentoo IRC is simply the best. If you running into another issue they will ask you straight away (mostly). Use termbin to post your terminal output. please see http://www.termbin.com/

let me know how you go.

here is the output from ifconfig. I will try net-setup, but I using a live cd would kinda defeat the purpose of installing gentoo to learn how linux works. As for ubuntu that is what I am currently using, I am just install gentoo in a virtual machine inside ubuntu.

I tried running emerge net-setup and it said that there are no ebuilds for that.

to learn how linux works

People say that about Gentoo. People say that about Arch. People say that about Linux From Scratch.

I've tried them all, stuck with arch, and found that the best method to learn how Linux works is to run servers and get involved in development, if you've got the skills for it.

Now, to answer your question. Based on what I remember from the install process, it looks like you're trying to set up the network configuration to the installed system, not the livecd, correct?

If so, make sure you're in the /etc/init.d/ directory, since that's where the startup files, or init scripts, reside. Aside from that, the command is correct, so I'm not sure why you'd be running into that error. the ln syntax is ln <target> <link name>. If you are, try adding an f to the flags so the command looks like this: ln -sf net.lo net.enp3s0. This will force the link, if the kernel doesn't explicitly deny access to the directory. It also allows the creation of broken links, so we'll need to be careful of that.

I'm going to spin up a gentoo install box right now so I can try to reproduce your error.

I feel so stupid. I was typing ls instead of ln. Thx for your help though.

Well this is how we learn. I'm surprised I missed it as well. Glad to hear that you got past it though.

Hi Tex,

Sorry I have been fairly busy and haven't check the forums.

So I just want to check your issue ?

the ifconfig output shows the network device is detected. (good)
it looks the dhcpd has already assigned it a network address of 10.0.2.15 (good)

It look from the pic that your network is already setup.

Gentoo install medium most auto-detects ethernet networks.