Mono.dll library error Rust

Whenever I try to launch Rust I get "Unable to load mono library from "G:/Steam/steamapps/common/rust/rust_Data/Mono/mono.dll" (error = 998)." I have tried updating my .NET framework, verifying steam cache, clean reinstalling, and even downloading a new mono.dll but nothing works.

Believe it or not, it's probably blocked by you anti-malware software...

Yeah mono, C++ nonsense...sigh


The only problem is I disabled all my  anti-virus/malware shields to see if that was the problem and still the same error


view intregity of game cache?

I already did that. Thank you for being more responsive than the actual devs and players though.

Considering that the game is still in alfa/beta you would get better help from the developers forum. And they would also be interested to know how that happens and how to fix it.

Even De Icaza has come out and said what's wrong with mono... C++

Everything De Icaza ever did, ws nothing but open job solliciting towards Microsoft... he never got the job, and it drove him nuts to the point of leaving linux and joining Apple as the ultimate act of desperation lol

Ok you have told me its C++ but would you happen to know what I can do to fix it?

Hey, I want Rust for linux to work too, but it doesn't. In Windows, normally if Rust won't start, it's because of the mono libs that are blocked because they are falsely recognized as malware. I said that right along. I'm afraid the only other solution, if that doesn't work, is to wait for the devs to clean up their unholy coding mess in Rust, and it would be nice to see Rust work in linux for once, it's been out of commission for weeks, and not all legal systems attach a full exoneration to alpha or beta status. Bugs is one thing, completely not working for an entire platform is another thing. If they don't make it work somewhat really fast, they're going to get a class action on their stupid arse for a complete refund of all linux sales plus a cease and desist order with relation to "linux compatible" mentions. This is really pissing me off. Who does that, sell a game with very little content for a premium game prerelease price, advertising compatibility on linux, and not succeeding in even making it work a little? A clear case of Misrepresentation...