Monitor Refresh Rates - Ubuntu MATE / NVIDIA FFS

Hello all,

image

Had my Ubuntu MATE system (22.04) perfected, was using Nvidia 510 drivers. Everything was tight. At random looking at nvidia-smi I noticed the power draw elevated at idle. About 75 Watts. Did some research and it was a known issue and was fixed in the 515 driver.

Updated to 515, cool power draw normalized. BUT…my monitor no longer could be set to 144hz. If I tried, it would go standby. Wouldn’t revive until reboot. Settings would not stick.

Tried via the additional drivers gui and straight from NVIDIA (heh). Figured I would need to go to most recent release for the newer drivers, gave that a try…nada.

Tried addressing settings directly in xorg.conf, tricks like set in nvidia settings and then the ubuntu display app and vice versa…nothing. Straight to standby.

Turned off and on the monitor a few times. Unplugged it, everything.

So what do I know, it works on Windows 10 at 144hz, it works on 22.04 and 22.10 with nvidia 510 drivers and nothing else. But the excess power draw…

Please offer guidance y’all, I am begging you.

before I forget the system:

Gigabyte 3080 TI Vision
Gigabyte M32U (4k 144hz)
Some LG 4k 60hz monitor

CABLES CABLES CABLES - all HDMI 2.1
Original Cable that came with monitor
Monoprice cable (successfully works for 4k 144hz driver 510)
Club 3D

Window Manager: Marco: XPresent

Ubuntu Mate 22.04 and 22.10

Proprietary NVIDIA drivers 510,515,520 and respective open kernel drivers if they exist.

Thank you all,

WWED

Shameful BUMP

Have you tried a different Linux distro to see if it’s just mate

And did you try a fresh install of mate

1 Like

Let me try a different dist.

Tried fresh install of Mate, two most recent releases.

1 Like

Does the option appear when only the fast pannel connected? I’m sure you unplugged the other one to test, but maybe?

Gonna try a different dist.

But this is what Nvidia forums came back to me with

[     9.787] (WW) NVIDIA(GPU-0):     3840 x 2160 @ 144 Hz
...
[     9.787] (WW) NVIDIA(GPU-0):     Unable to determine HDMI 2.1 Fixed Rate Link
[     9.787] (WW) NVIDIA(GPU-0):     configuration.
[     9.787] (WW) NVIDIA(GPU-0):     Mode is rejected: Unable to construct hardware-specific
[     9.787] (WW) NVIDIA(GPU-0):     mode timings.
[     9.787] (WW) NVIDIA(GPU-0):     GPU extended capability check failed.

Usually, this points to the mode requiring DSC which isn’t supported by the linux driver. Since this worked with the 510 driver, I suspect nvidia lowered the threshold for when DSC is needed.

What do you guys think…my response is…Ok, but why would they do that.

@wendell Has this come up in your exhaustive GPU/Monitor Linux testing