Monitor HDMI 2.0 port not working on some devices

I have a Westinghouse WE40UX8310 (40 inch 4k monitor) that has DP and HDMI 2.0.

The HDMI port does not seem to have the correct EDID (I’m guessing) because my computer when plugged into the HDMI port defaults to 4k30hz. I can create a custom resolution of 4k60hz and it works(runs ufo test and gaming I can tell its not 30hz anymore even 4:4:4 Chroma [email protected] 4k60hz) This work around is fine for my PC.

When I connect an NVidia shield or Xbox one x I’m stuck with either 1080p 60hz or 4k 30hz and I am unsure if there is a way to use a custom resolution on either of those devices or IF I can some how fix the EDID in the Monitor?

Have you tried other cables?

I have tried 2 different HDMI 2.0 cables

What lengths? Hdmi 2.0 is a standard for the port not the cable, a certified hdmi high speed cable is only tested for hdmi 1.4 speeds at the minimum length so its possible that any high speed cable, but especially ones over a couple of meters, could have trouble getting the full hdmi 2.0 speed when doing the handshake.

I had this same problem when using a 10m cable (although I never tested a custom resolution) and had to get a fibre cable to get full speed. I also had artefacts on a different system with 1.5m cables and had to replace them with cables that had been tested for hdmi 2.0 speeds.

I can try a different HDMI cable when I get home from work . The packaging said it was a 18.6gbs cable with a length of 6ft (approx 1.8 meters?) and says 4k on it. Maby they mean 4k30? Is there something else I should look for in a cable?

bought a new cable that was 4k certified. still cant get 4k60hz to work without the custom resolution