Return to Level1Techs.com

ML350p gen8 Storage Controller Driver will not install

I have an old girl we are trying to get going as a test environment to train people up in. The system will install Windows Server 16 fine. When I boot the machine it will not make it to the login screen with the Smart Array P420i Controller enabled in the bios it stalls on the Windows splash screen with the rotating dots.

If I disable the controller the OS boots fine on the SATA SSD. Problem is when the Storage Controller is disabled it will not install the drivers.

Barks at me "The software will not be installed on this system because the required hardware is not present in the system or the software/firmware doesn’t apply to this system. "

Lastly, I know the controller is good, I have been running a Linux based OS off the raid for almost a year before we decided to make this change.

Is there a way to force the drivers to install without the device on? Or sideload the drivers? I just need this machine to make it into Windows Reliably with the raid enabled.

Thanks!!!

How did you install Windows, using the HPE installer, or brute force from a Windows USB key?

I’ve never tried running 2016 on that old of hardware. It’s also not on the support matrix from HPE.

Just to prove the hardware is OK, try installing 2012 R2, using the HPE installer.

I have a DL380 G8 I might be able to try this on over the weekend.

Oh, do you have the latest SPP or firmware installed?

I brute-forced it with a USB key. It does show in the hp support matrix that it should work lol. I’ll give the 2012 R2 a shot.

Far as the firmware goes I tried via the iLO but it returns a broken URL error with no way to procede with manual firmware installation.

Thanks for the advice!

Talked with a colleague and they have 2016 running on G7 hardware, so G8 should be no probs right!?

For your firmware, download the latest SPP, boot it directly and let it do it’s thing. You likely need an ILO upgrade to fix that bad url error. They keep fiddling with both the built in url, and I think TLS.

Thanks Gordon, fresh admin been on the job 3 months. So thanks for taking the time to give me a path to try. I was out of ideas. :smiley:

Crap didn’t realize all the spp files are entitlement only. I hate HP for this lol

There are alternative sources, but those are against the rules to discuss here.

Last I looked the ILO firmware is “free” to download, and that might let you manually upgrade the controller firmware.

Yea that is the route I am currently going down. Going to update iLo then hopefully I can get what I need.

1 Like

Well, I just am now getting back to updating this post.

Things I have attempted

  • Updated the iLO firmware to the latest version, still can not successfully use the HP tool built into the machine

  • Download the SPP and gave that a go, would not boot, maybe a bad SPP so I am not totally finished exploring this option

  • Tried installing Windows 2012 R2, the same lockup occurs when the windows banner flag is up and the circles are forming.

I am pretty much out of ideas about what I could do next to get this machine on a Windows Platform and retain the raid functionality.

Again Windows Server 16 and Windows 2012 R2 both function fine without the raid enabled.

I guess I am going to take the machine back to Linux until I find a solution for this, so frustrating not being able to get around the HP Paywall to use a very expensive piece of gear albeit old. Especially since this machine is listed to be supported by both R2 and 16.

Are you using Intelligent Provisioning to install the OS?

When you say that the SPP wouldn’t boot, did you use a USB 3 or USB 2 thumb drive? I believe USB 2 is the recommended method. Trying to boot it from inside ILO might not work either.

If you can boot the OS with the raid card pulled, you can run SPP that way as well.

Okay, it was a USB 3.0 its all I had in the shop, I’ll have to dig up one of the older drives.

Used Rufus to put the SPP on a USB and then booted straight from the USB, hit a linux prompt with a “Failure to boot”.

The install that is on the box atm is Windows 2012R2 which I used a USB to install. I tried using the Intelligent Provisioning to install once as well, it did not like the bootable media I had in. Is it looking for an ISO?

I can see why my entire shop moved over to Dell and handed this to me (the new guy). What a nightmare.

Strike that about the ISO, it didn’t like that either, man alive HP is making this waaaay harder than it should be.

I.P. wants the ISO unpacked onto a USB thumb drive, I would use USB 2.0 to be safe. Rufus should do the job.

Burning the SPP to a USB should work. Make sure you select MBR as the boot option in Rufus, if I’m recalling that correctly.

My shop is 90% HP, with two Dell in the mix. I find the HP a lot easier to manage, not a fan of Dell’s iDRAC solution. But I’ve been drinking the HP koolaide for more than a decade so kinda grown comfortable with it I suppose.