Mint 19.1 no longer can access samba shares after install of VM

Hi there I have this issue and no solution that google has pointed me to has worked
I just did a fresh install of Mint 19.1 and did a PCIE passthrough install of win 10 on KVM according to Wendell’s wonderful guide for ubuntu 18.04. prior to getting the VM going I could just browse to a couple of samba shares I have on a separate machine that I backed up all the data too. After getting the VM with the win 10 installed I can no longer browse the shares they dont show up. I get the message that the path cannot be found. My other machines can still access the shares . I can ping to the machine from Mint, the firewall is inactive in the smb.config file I have the line, client max protocol = NT1 that did not fix it. checking the status shows smb is running and not returning any obvious errors. I am a noob when it comes to linux so not sure where to go from here. FYI the computer hosting the shares is running ubuntu 18.04 and configured at the moment to allow anonymous browsing of the shares ( i know not secure but it’s just me and the wife at home plus trying to eliminate a permission issue)

Ran into some problems mounting samba shares a little while back. This thread helped. Ensure that the following is done exactly as required and see if that helps.

Edit /etc/samba/smb.conf and under the “workgroup = workgroup” line add these two lines:

client max protocol = SMB3
client ipc max protocol = NT1

Then restart smbd:

sudo service smbd restart

Also followup with a reboot and see if that works.

Sorry that did not work
I went through that thread and think my problem may be similar, I tried to do a manual mount through cifs with this command

sudo mount -t cifs //server-name/share-name /mountpoint -o guest
of couse adjusted for the names of my server and such, returned mount bad usage so perhaps I entered it wrong??

If I could use another program to create a mountpoint that would load on boot or something like that it would be an acceptable workaround as it sounds like this may be specific samba bug but I wonder why it didnt show up before I created the VM?

So I just booted into a live ubuntu and was able to almost insantly mount the shares no terminal required. I checked on it and samba was not installed so I wonder if I uninstall samba on my machine will Nemo fall back to using cifs or some other method to browse and mount the shares??

OK made a little progress. one of these days I must learn how to type. anyway removed samba, no help, got back into the command line and found out I can mount the shares if I put in the IP address of the server instead of the name (may have been bad syntax before or I cant spell who knows) so I guess as long I put the server on a static IP I can setup mount points and carry on.

THANK YOU for pointing towards that thread it was a big help

1 Like